Load, Edit and Save Multi Images

Hi, apologies, I’m new to Silver Efex - How do I load a batch of images into Silver Efex, (apply a film type) and save the entire batch. I can do this for individual images, one at a time, but can’t see how I do an few at a time. Thanks.

AFAIK, you can’t load a batch of images into SEP … you need to process images one-by-one.

The only thing I can think of to make this a bit easier would be to create a custom recipe/preset - so that you can readily apply it to each image … to make the process a bit easier to replicate.

John M

Hi, Chris!

I process batches of images with Silver Efex Pro and the other Nik apps most of the time. The workflow varies depending on your starting point, but here are three methods I use that might work for you.

One: If your images are in Lightroom, select all the images you want to pass to Silver Efex, right-click on the images then choose “Edit in Silver Efex Pro”. If you’re using RAW files, a copy of the image will need to be created; if the image is a TIFF or JPEG, you can choose to create a copy or edit the original.

When Silver Efex opens, any effects you use on the first image will be applied to the others in the batch: so, for example, if you open five images and make changes to the first one, they are applied to all five. If you then page forward to the third image and make additional changes, those are applied to the fourth and fifth image (but not to the first and second image). When you’re done, choose “Apply All”.

Two: If you’re using Photoshop, you can apply Nik Collection effects to multiple open images several different ways, using Nik’s Selective Tool that pops up in Photoshop. See this link for a tutorial on the different techniques:


Three: If you’re opening TIFFs or JPEGs directly from Finder, you can select multiple images, right-click and choose “Open with Silver Efex Pro”. From there, applying changes works like the Lightroom example above; when you’re done, choose one of the Save options from the File menu.

There is one kink with this third option: if you have Lightroom on your computer and it’s running when you select the images from Finder, the File menu isn’t available in Silver Efex Pro. This is probably a bug in the software, but in this weird case, you can use “Apply All” instead.

Hope this helps!



This is very helpful, thank you! I think your third option may work for me. I’m a Capture One user, so save the image after some simple edits as a Tiff. I’ll give it a go - thank you!

1 Like

Thank you!!

Thanks, the third option imports all the images, which saves to much time! The Save All option is good, but it defaults to the Tiff option. Thanks again.

1 Like

You’re welcome, glad to hear it worked out for you! You probably already saw this, but you can use “Save image as” instead if you want to change the file type. If you have multiple files open, you have to save-as them one at a time, but it still goes pretty quick.


I used to open several tiffs with the Silver Efex Pro 3, edit them, save at the end and the program would process all the files, one and at a time, until it was finished. Now, I don’t understand why, if I save, the program only processes one of the images and not the rest.

My tiffs are generated in Capture One 23. I’ve tried opening them from C1 (Tiff variants) but also from Finder (Open with SEP3) and the result is always the same.

Any help available?

System: macOS Ventura

Thank you very much

I have Lightroom, not Capture One, so couldn’t try out your scenario exactly, but I have noticed some inconsistent behavior with Silver Efex Pro when opening files from Finder. However, one of these two options should work, regardless of how you open the images for SEP:

  • if there is an APPLY ALL button in the lower right corner of the screen, then you need to press that to apply changes to all the images.

  • If there is no APPLY ALL button in the lower right corner, then you should use File/Save All (from the Silver Efex Pro menu, upper left). If you use File/Save instead of File/Save All, changes will only be applied to the image showing on screen.

There is no keyboard shortcut for File/Save All … so if you’re accustomed to using cmd-S to save your changes, that only works for one image at a time.

Maybe that helps?


Hi Dale,
thanks so much for trying to help.
I just have a button in the bottom right hand corner that says “Apply” (another for “Cancel”).
In the menu at the top there is only “Edit” and “Help” apart from the “Silver Efex Pro 3” menu. I don’t have access to “Save As”, “Save” or “Save All”.

Is it maybe because I have Nik Collection as an application connected to Photolab 5?
Could it be that by reinstalling the collection and avoiding that it is an application linked to Photolab 5, the collection will working independently and autonomously and therefore with a more complete menu and more editing and saving possibilities?

Thank you very much.

Hello Dale again,

I did the following; uninstalled Photolab 5. Uninstalled and reinstalled Nik 4 again and as such only allowed to do the suite installation as a “standalone” set of applications. This time I already have the “File” menu and the possibility to “Save”, “Save image as” and “Save all”. So it already processes several images if I choose “Save all” ,-)
Anyway it’s a procedure that doesn’t make much sense. DxO should fix this.

I’m going to install Photolab 5 again now and hope everything doesn’t go backwards…


provided there is no big difference to the Mac version

  • when used as STANDALONE
    the options to apply & save reside in the file menu / top left corner

  • when used as PLUGIN
    the available options are found at the bottom / right hand side
    (batch mode depends on the host program)

Thanks for your help Wolfgang.
I have Nik installed as a Standalone suite. I have not reinstalled Photolab 5 again yet.
What I use the most is the Silver Efex Pro 3.

Now the strangest thing happens for which I have no answer:

  1. If I open some tiffs from Finder with ““Open with”” and choose SEP3, the program opens them and shows the “File” menu. Before this operation I closed Capture One 23 where I exported the Tiff files, from .raf raw files (GFX50R).

  2. If I do exactly the same but leave Capture One 23 open, SEP3 opens the images but doesn’t show the “File” menu. It does, however, show the “Cancel” and “Apply” buttons in the bottom right hand corner. The problem is that this “Apply” button doesn’t process all the open images, but only one of them.

That is, it seems that SEP3 “thinks” that C1 is a “Host” compatible program and stops behaving as a Standalone application. Curiously C1 is not part of the programs that DxO indicates as compatible with the Nik suite. By the way, to minimize this strange connection, I have disabled C1’s plug-ins prefs so that it cannot “Edit with” and “Open with” other programs.

All this is strange and makes me lose time ,-(

well, I don’t have C1 and am on Windows …

  • SEP3 used as PlugIn from PL5
    I selected 4 different files ( 1x jpg, 3x raw → .rw2/.raf/.nef )
    and could batch process them
    of course only with the same setting

I just did that with 9 Tiff files.
With the same my Custom Preset on all images. I do “Apply” and only one is processed. If I make a separate Custom Preset for each image, only one image is processed. C1 open.

If I do the same with C1 closed before opening SEP3, even if I apply a distinct Preset to each image, I can again do File>Save All .-) and all images are processed in a row, with the right and distinct Presets, that I applied to each one.

Either it’s a bug or something is still eluding me.

This is actually the same odd behavior that occurs on my system with Lightroom. Even if I open images using Finder, if Lightroom is running, SEP seems to think I’ve come from Lightroom and offers the “Apply” button and there is no “File” menu. It even says “You’re modifying images from Lightroom” at the bottom of the screen, despite the fact that I opened them with Finder. That doesn’t really help you, other than to confirm that what you’re seeing occurs in Lightroom installations as well as Capture One.

One thing I have noticed is that even if Lightroom is running, I can launch SEP directly (that is, without opening it with an image via Finder) and the File menu is there. I can then use File/Open to open multiple images (pressing the CMD key and selecting more than one) and SEP allows multiple saves using File/Save All. SEP stays open after it updates the images, and I can use File/Open again to work on some more.

Thank you.
For that is exactly what happens with the C1, just like with your Lr.
It’s a problem that DxO should fix because it doesn’t make sense.