Lightroom Classic, export to PureRaw2 on an iMac fails every time

I have tried mightily to export Nikon NEF files from Lightroom Classic (latest version) to PR2. With all that I have tried I get a message (from PR2?) “Sorry! An error occurred while launching the DxO PureRAW2 plug-in”

I have tried reinstalling cleanly, opening different NEF files, open files on the internal drive and on the external RAID device. I installed the patched PR2 from DxO support. Nada, zip, zilch - nothing has resolved this failure to export to PR2. I have an iMac 2019, 40GB RAM, i9 processor and the latest Mac OS. I can open and process the same files in PR2 directly without issue. … just not via the export from LR Classic.

Suggestions? Am I so lucky to be the one anomaly to encounter this problem? :frowning:

Any help will be appreciated.


What file format is being exported from Lightroom?

Pure Raw only supports original RAW files

Ignore. I couldn’t delete this post.


… DxO support has already looked into it and did not find the issue?

I assume that the export via the LR File->Plugin Extras->Process with PureRaw2 is sending the Nikon NEF directly without conversion. The NEF format and the Nikon D750 model are well supported by DxO. This is demonstrated by the fact that I can load and process the NEF files directly via the PR2 Add Photos To Process menu. The NEF format is the Nikon RAW file format and is hardly the “new kid on the block”.



I am not sure they resolved my specific bug, but they did have me try a patched version of PR2. Alas that did not result in a successful LR plugin → export to PR2 process.


I was hoping a recent update from DxO would fix this. I cannot be the only one encountering this issue. It is not the way software/configuration bugs occur. Sadly, I am not able to launch PureRaw 2 from Lightroom Classic on my iMac (Intel) The frustrating thing is that the error message gives no details. So much for a flawless workflow.