Lens sharpness greyed out for DNG files, OK for CR3

When I open a CR3 file from my Canon EOS R I am able to enable DxO module based lens sharpness, Vignetting and Distortion corrections. When I open a DNG file created by Lightroom from the same file Vignetting and Distortion corrections are available, but the lens sharpness is greyed out. This occurs with both the RF lenses that I own.
My Olympus body and lenses allow correction of distortion, vignetting and lens sharpness based on DxO modules for both raw and DNG formats.
DxO Photolab is version 5.1.2 build 53, reported as the latest version.
Ideas as to the lens sharpness is greyed out for the DNG file?

Not the case here (macOS 11.6.5, DPL 5.1.3 build 55) and I suppose that your issue is caused by some processing done in Lightroom (and respective metadata entries?).

Please check how you’ve treated the image in Lr before you exported it.

Thanks for taking the time to reply.
I was using the DxO plug-in to transfer the DNG to Photolab, not exporting a TIFF. File | Plug-in Extras | Transfer to DxO Photolab 5. My understanding is that Lightroom does not do any processing before transfer. This is in contrast to “edit in”, where a TIFF file is converted and opened in DxO. To be sure I used Adobe’s DNG converter and got the same result; no lens sharpness available. Then I tried the same on a sample file from DPreview. the raw file at:-

View Canon EOS R sample gallery from DPReview.

I also used another computer with the same result; CR3 files under DxO allow lens sharpening, but for DNG (from the converter, not Lightroom) it is greyed out.

DxO support has yet to offer a reply.

From your original post, I read that the DNG was created by Lr. Now, I read that the DNG was done by Adobe DNG Converter. This should make no difference though…

My testing has results from generating DNG from both Lightroom and Adobe converter with the same results. There is no difference as you say.

Tested with two files I got from DPReview (and found the same issue as you did, pluas a loading error…

I also found that DPL proposed seven modules (for two shots!)

Attn. @StevenL

Test images used: Flowers, Fire


@stewart.logie , the lens sharpness is greyed out when MakerNote (form Exif) is missing (some information needed fo lens sharpness correction are from the MarkerNote and are not available in dng parameters), can you look in your export option in LightRoom if you can have it saved ?

Concerning optics module association for Canon we will work on it to reduce number of modules proposed if the one you are looking for doesn’t exist (yet) or if lenses have same Exif properties.


Thanks Marie! I have discovered that the Adobe DNG converter strips off the maker notes from .CR3. There is no option that can be set to allow it. Adobe has not done the work.

Optics modules was not part of my question. That was brought up by another user.

1 Like