Latest PL version issue

PL 5.12 built 93
macbook pro m2

some bug issue in this version.
the left panel ton and off result in next adjustment not showing. to fix the issue i have to click “view full screen” then back to normal. this occur with every single time i open a new image to be process.
another bug is with some adjustment panel, doesn’t matter how many times i try to save my workspace, there’s always adjustment that don’t save and i have to head back and double check everything. things like purple fringing, moire, distortion “keep aspect ratio”.

I don’t see anything unexpected with DPL 5.12 on macOS Sonoma Beta2 on M1 MacBook Air.
Note: I’ve installed DPL5 not as an update, but with a full installer. You can get it from your shop account or if you’ve trialed DPL5 and have kept the email.

I always do the same, never updating from PL itself but a fresh download.
I’m on Ventura 13.4.1

Strange… I don’t suppose that your download has been damaged, but you could try to uninstall DPL5 and reinstall it from a fresh download.

Sometimes, a cleanup is necessary before re-instrallation. Find PhotoLab 5 files and folders spread all over your Mac. I use “EasyFind” for such endeavours.

nope, downloaded from my account and same issue. opening and closing left panel result in freezing the screen and locking any further adjustment to be processed.

here’s a screen recording, you’ll see upper screen when i opend and close left panel that double clicking the screen to zoom in, it doesn’t work but the numbers changed (follow the cursor). then i have to click “esc” to get off full screen. another bug that occured… black screen for unknown reason without me touching anything, then clicking the screen it came back on.

*mmm can’t upload screen recording, neither mp4 or web.

Make sure it is an mp4 file.

Have you checked updates to your graphics card ?

it’s all up to date, no worries but can’t upload video, even if i change the format.
i was also wondering how to stop the recording =]

  • i only recorded issue with left panel, not covering adjustment saved with workspace as i wasn’t sure if we could upload video

Sharing the video is a better idea anyway…and I can now see what you’re dealing with. I can reproduce the behavior ( :beetle:) on an Intel iMac. Have not tried it on Apple Silicon yet.

I suppose that we see an effect of DPL’s way to handle zoom levels. I consider that way as, er, buggy or not well thought out or not well implemented, short: user unfriendly. Here is what I see in general:

  • DPL does not accept all values.
  • DPL seems to keep zoom levels “magnetically” until an unspecified threshold is reached, at which the viewer snaps to a new zoom level.
  • Adopted zoom levels don’t necessarily correspond to the percentage shown in the box: Manually entering the number shown, e.g. for “fit to viewer” can result in a changed size shown by the viewer.
  • Launching a tool that adds a toolbar at the lower edge of the viewer changes the zoom level, if the level that was set before launching the tool is too close to a “magnet” value. When the tool is then closed, the zoom level returns to what was set initially, but not necessarily in all cases.

I see two ways for DxO to fix the issue:

  1. Get rid of the magnet effect and redraw the image with exactly the zoom level that is set in the box and vice versa. Get rid of the magnet effect and, again, get rid of the magnet effect!
  2. Replace the zoom level selector by buttons fit, 100%, plus and minus, and make in-between zoom levels unavailable. This could also speed up redrawing, if the levels were set accordingly (e.g. 50% = binning 2x2 source pixels for one screen pixel as well as profiting from Apple’s true vs. shown screen resolution)

Magnetic zoom posts/threads

your magnetic zoom feedback is “page not found”

i didn’t know if video could be uploaded or not but it’s nice you can record screen video =]
not sure why zoom an image and side panel are affected, which is weird.

Not sure if the effect is a feature or a bug, but I tend to see it as a bug.

…it points to a thread I started in 2019. I’ve removed the link from my post above.
Anyways, the strange zoom behavior is old, I’ve just verified it in DPL2. Was unable to test DPL1 because it is not fully working on macOS Monterey.

seem the issue has been fixed with PL 5.13 built 94
tried to replicate the issue and so far so good.
thanks dxo for this quick fix.

seem this issue is back, tried with 3 different pictures and they all end up with the same issue first reported. open the left panel then close it, zoom in won’t work and back to full screen then escape to return normal, screen goes black for few second if until you double click it.

could that be just with M2 Mac?