Latest Photolab update freezes

Latest download freezes at 59mb. Have restarted computer with same result. Anyone else had this problem?

Me too.
I noticed an option in the browser to resume the download.
I clicked this and it resumed and completed.
Previous releases were ok

Thanks for letting me know this. Having gone to downloads in Google Chrome browser I found the resume option you mentioned although it took about five times to do this in download stages with the system reporting network failure each time in between. I assume there may have been a problem with the ISP. or maybe something else if anyone has any ideas? Finally installed OK.

How fast is your internet download speed? It varies greatly and this happens to me when download speed is very low.

Good morning,

Thank you for the info. Let me ask @htran to have a look at it.

Svetlana G.

No problem here. Win 10 with the latest huge update. And FF.


Difficult to believe it’s an ISP issue as lots of people are experiencing it an it’s only just begun.

the issue is still actual?
i checked on my side (on 2 different PC), no issue.

Yes it is still a problem. I have tried to download maybe 12 times since 3pm yesterday and just now and never managed to get past about 60MB.

Yes - still a problem - but i am on a Mac ( i know this is the windows thread) I have tried maybe 10 times since yesterday - opened ticket [#256411] with screenshot

Ditto here :+1: - with Chrome.

John M

Hi Rob.
Have you tried the ‘Resume’ option?

Yes, finally got there in last few minutes after resuming about 10 times.

No problem with download and installation on Win 10

So, it may have an issue somewhere, we investigate right now

Just trying a download on windows 10 now - it’s stuck on 48.0/412 MB. This is the first download of PL where I’ve ever had a problem. I tried Pause / Resume over a dozen times with no success. Then I cancelled the download and started a new one via “Check for Updates” in PL4 - this got a bit further (75MB) then paused, then reported Failed - Network error. I resumed this download and it got further (!94MB) then hung again. I cancelled the download for a second time then restarted a new one again via PL4 - this time it’s hung at 66MB. I guess I’ll give up for now and try again later.
(I’m using the Chrome browser)

36mbs download speed

No problem yesterday at 15:36 with Edge browser :grinning:

Windows 10 64-bit 20H2 19042.867
Edge Version 89.0.774.45 (Offizielles Build) (64-Bit)

Windows 10_2004
MS Edge Version 89.0.774.45 (Official build) (64-bit)

Entire process including install took about 120 seconds.

No issues.

I just download via Firefox and it’s ok
Yesterday since DPL it was ok