Interface is driving me crazy. Please give the option to turn off sliding animations in panels

Forgive me if this is possible and I’m just not seeing the option, or if there is a workaround that I haven’t found yet. But the sliding animation of the panels in CEP 5 is really getting annoying.

First of all, I love, love, love the filters and plugins, and will continue to use them daily in my work and my creativity. That being said, I’ve been using CEP and Nik plugins for at least 10 years and the interface has always been so quick and minimal. It was one of my favorite things about the plugin suite.

With the latest versions of CEP, it feels like there is too much “showiness” with the way the panels slide open and how things try to be smooth. But it causes me more frustration with how clunky the interface has become. And the scrolling of my mouse through the filters and recipes is jittery and jumps all over the place. As well as I used to be able to hold down my 3rd button on my Wacom pen which was set for scrolling to move through the lists of filters, but now that just doesn’t work at all.

Oh… and why doesn’t an UNDO shortcut work? It hasn’t worked for several versions now and it’s getting a little bit annoying as well.

And before people say to check my system, this happened on my 2016 iMac, my 2019 Macbook Pro, and now on my 2021 Macbook Pro M1. Plenty of RAM on all 3 systems, as well as plenty of HD space and all of them running off SSDs. This is a problem with the interface of CEP and all of the Nik Efex plugins.

Is anyone else having this issue, and has anyone found a way around it? I love the actual meat and potatoes of the plugin and its filters, but the interface is driving me insane.

Hi, Jesse.

I agree with everything you said above: the way the panels bounce when scrolling sometimes even gives me a headache as my eyeballs try to bounce along with them.

I recently found a workaround that helps, even though it’s not really a solution.

I’m on a Mac mini using Ventura OS and an Apple mouse. In System Settings, under Accessibility, I go to “Pointer Control”, then select “Mouse Options” – and do one of the following.

  1. Turn off “Use inertia while scrolling” – this (mostly) eliminates the bouncing. I then also adjust “Scroll speed” so scrolling works faster and the bouncing becomes even less apparent. OR:

  2. Turn on “Use inertia while scrolling” and set “Scroll speed” to its highest value.

The inertia setting (which determines if a scrolled panel or web page stops gradually or abruptly) may not be available – if you’re not on Ventura or not on a Mac, and depending on your mouse or its software – but even cranking up the scroll speed helps quite a bit, and scroll speed should be available on any system or OS. These are global settings, of course, and will affect other things you scroll with the mouse, but at least you could adjust it while using Nik tools and set it back if you need to.

Hope that helps a little bit, or at least gives you some things to try…