Integration with Photo Supreme Ultimate regressed

This a minor problem but it is a regression.

I use Photo Supreme Ultimate v. as my DAM. I’m staying on PL5.5 (until Fuji support is fully added to PL6). In the past, when I selected one or more RAF thumbnails and hit the DxO Photolab button, PL5 would launch, if necessary, and I would be in the Customize tab with a navigator strip showing all the selected thumbnails.

Now when I hit the DxO Photolab button in PSU, I get an empty Customize tab with a navigator titled “No images selected”. I can resolve this by switching to the PhotoLibrary tab, then back to the Customize tab, where all the images then appear correctly.

The only relevant change on my workstation that I can think of is that I downloaded and installed PL6 to evaluate it. I have since uninstalled PS6.

I wonder if I have to uninstall and reinstall PS5.5 but I want to get advice rather than just forge out on my own.

Thoughts, anyone?

I use PS 7 as well and have PL6 installed. I am able to open PL6 with images from PS. Did you recreate the link from PS in case it got broken by 6 back to 5? Its an easy one to forget only having to do it every year or so, under Other Services in Preferences.

I had initial problems with the integration with Photo Mechanic but they are solved. I had to reconfigure the file support in Photolab and after that it works fine again. I also think it might be the case that PM Plus 6 and PL 6 integrates better than before when it comes to the synchronization function that now benefits from the improved XPM support in PL 6 that now uses XMP as a default.

I deleted the integration in PSU by visiting Preferences - Other Settings where I deleted the button for PL5. When I recreated it, the problem persists. I don’t know where or how to effect the integration features within PL5.

I think the problem lies in PL5 because the selected files are definitely passed correctly. Only the initial display in PL5 is incorrect. To repeat what I tried to say above, the simple act of switching to the PhotoLibrary tab, then back to the Customize tab, corrects the problem.

Thanks for your thoughts. I never integrated PS6 into PSU because I was evaluating the keywording capabilities and the stacking/versioning capabilities of the PhotoLibrary. (The keywords are fine. Organization by stacking RAW + JPG pairs is not implemented yet, so I ditched my evaluation.)

I think it is a BUG. I uninstalled PL5 and installed version 4732. This worked fine launching from PSU. Then I upgraded to version 4770 and the integration failed in the way I described above.

I also had this problem - Photolab failing to open in Customise with files sent from an image viewer program.

Discussed in this thread: Strange behaviour when sending images to Photolab from another program - #37 by David_McA

Good news. The bug is going to be fixed.
DxO Staff: “The bug is identified and will be fixed in a minor update of DxO PhotoLab”.

David McA

1 Like

This problem still exists in Has anyone found a work around without going into Finder or searching for the image in DxO and updating the PSU database afterwards?