Install of PL4 on iMac fails

That’s not gone well. Downloaded trial, tried to start. Here’s what happened:

  • Loading database and parameters. Stuck. Closed app and restarted iMac
  • Loading DXO Optics modules. Stuck. Closed app. Uninstalled app. Restarted iMac. Installed app
  • Loading…

Closed app. Wrote this. Gave up. Gone for a cup of tea.

UPDATE: So thank you to KameraD - the issue was the size of my db. It would be a good idea for the install to do a quick look at the size of the db prior to starting install process, in order to display “This installation may take some time. Please be patient”

I estimate it was about 3 cups of tea worth. Maybe less, because I wandered off.

That is what exact happens to me and others too. Went through this meanwhile also with help of the support team. It seems to be like this, depending on the size of your database, mine was more than 2 GB and the spec of your Mac, that it could really last more than a cup of tea. Maybe a good advice could also be to do this during the night. You may like to read also my post to this, PL 4 stuck after start while importing database and parameter
Or just follow this instruction, for a quick and dirty solution.

  1. If you want to use PL 3.3 also in future
  • move the database ~/Library/DxO PhotoLab v3/DOPDatabaseV3.dopdata to the desktop
  • trash the already build ~/Library/DxO PhotoLab v4/DOPDatabaseV4.dopdata
  • trash also ~/Library/DxO PhotoLab v4/DOPDatabaseV4.dopdata_output
  • start up PL 4
  • move PL 3.3 database back
    This way you will start from the scratch. But if you like me, don’t have used keywords or such, this works fine.
1 Like

No issues whatsoever with the installation on macOS Mojave, Catalina and Big Sur Beta.
Data migration and a few other things can be improved though.

I had the hang on first start but force quit and restarting the app fixed it.