Install dxo Film Pack 6 - some troubles

install dxo Film Pack 6 as integrated in DXO Lab 6 Elite and standalone and Photoshop (3 locations)?

Welcome, Kib. Can you explain a bit more what your question is about? Page 9 of the User Guide covers installation: it’s rather simple. When you run the FilmPack installer, you’re installing the standalone software and a plugin for Adobe software. If the installer doesn’t automatically detect the location of the Adobe software, you can specify it through a browser. No installation is needed for integration with PhotoLab 6 Elite: just run PhotoLab, and in the help menu select the option to activate FilmPack - or verify that FilmPack 6 is already activated when you start PhotoLab (the license key will appear on the splash screen).

Another problem - but leave it alone - I have brought it to their attention:
When you enter via Lab 6 Elite and want to activate FilmPack 6, by purchasing (via Buy), you end up upgrading to… Lab 6 Elite, which I have (not Film Pack), and it is clearly a mistake - I have made them aware of it and sent 2 print screens.

So: It does not load on my laptop (as it did 1.5 years ago on my desktop) automatically, as you write.

New: When you go in and check on their site, it says:

Installation and activation • DxO FilmPack 6 is already included in DxO PhotoLab 6, and can be easily activated via the Help menu (PC) or the DxO PhotoLab menu (Mac). • The standalone version and the plugins for Photoshop and Lightroom can be installed by downloading and executing the appropriate installer found on the DxO website (

But when you go to there is nothing about this installer.

Is this the problem?

Sorry I posted this question on W11 but couldn’t find it on W10 and this is about W10 if that makes any difference.

I bought the Lab 5 Elite 1.5 years ago and at the same time I got a sample of the FilmPack 6, but I didn’t get to try it because I was busy figuring out DXO’s program, which was the first time for me.

But it “lay down” fine both on Lab 5 Elite (presets), as standalone and also on my Photoshop CS6 (even though they say it hardly does, it did, but it’s also a very strong PC with strong graphics card - 32 Ram and so on)

So it expired then before I had really tried it.

I then asked if I could have it again - and have tried to ask for just a 3-day trial, but no, you didn’t understand the problem, and you obviously don’t have competence even in a Force Majeure situation, as follows below:

They then advised me to try it on my laptop, but here it only loaded as presets for the Lab 6 Elite.

No standalone (that’s NOT OK)

No CS 6 (but that’s OK)

I think that an IT bug has crept in during the 1.5 years?