Incredibly sluggish performance on laptop

Hi, I just downloaded the version 6 of Photolab to try it out(I am a version 5 license), and frankly it is so sluggish on my laptop that it is unusable.

Laptop is a bit older, but still has an I7 6500u cpu, Quadro 500m gpu, 16 gb of ram and running off an m.2 ssd. All drivers and Windows(10 home)are up to date, Photolab is set to use discreet graphic.

Last night I rendered an image(raw image from Nikon D850), well it took over 6 minutes to render a single jpg.

Then I rendered the same image, with similar adjustment and destination, in CaptureOne and it took 6.5 seconds.

But it’s not just render time, the interface overall feels unresponsive, with hiccups every time I try to adjust a setting.

Photolab 5 is sluggish, but nowhere near as bad. By comparison, C1 is snappy and fast to use on this machine.

What’s going on?

1 Like

Just check with performance monitor. During the render Photolab only utilize 5% to 13% of the cpu(average is 7%), and 0% of the gpu.

With so little utilisation, temp is very low, fans don’t even come on in fact.

Power setting on the laptop is set to performance.

And it take f-o-r-e-v-e-r.

is there a possibility to set a performance mode on your notebook.
I also wondered yesterday when my new notebook has no GPU displayed, but then noticed that the silent mode was set. Switching to Performance mode has the GPU running at up to 30%, and the CPU at up to 40% every now and then.
100 .orf images with Deep Prime in under 5 minutes, but with louder fan’s
I first had to check if all images were really there. :grinning:

Windows 11/ DXO PL5 / Lenovo Legion with core i7 12th gen and NVidia 3070 ti

As stated in my second post, the power option of the laptop is set to performance already, with minimum and maximum cpu usage set to 100%.

It just seem that Photolab isn’t using ressources that are there.

1 Like

Sorry I don’t see this line in your post

I’m not sure but I don’t think that the Quadro 500m is fully supported. Do you see an asterisk * in front of the listing in preferences? If so you might want to try THIS HACK. Scroll down to the bottom to find the instructions.

The Quadro 500m was introduced in 2011, I believe. It is a very low end graphics solution. My GTX 1050 TI is at the low end of supported graphics cards for DeepPRIME and DeepPRIME XD and relative to the Quadro 500m its performance is over 900% better!


1 Like

Yeah, that’s kind of what I was thinking, but the hack still might speed it up at the risk of instability.

Yes there’s an asterix in front of the listing preference.
Not sure what the hack is supposed to do? Is it to disable gpu acceleration for deep prime in favor of general responsiveness of the ui, or the opposite? Or non of those?

Right now it is utilisin 0% of my gpu, and vey little of my cpu.

So, 900% of zero… It is still zero :joy:

This one.

It is supposed to speed up the partially supported GPU but at the risk of instability. I don’t know if it works, I’ve personally never used it as my GPU is fully supported but several forum members have reported good results from it(mostly with the AMD 580). It might not work on your Quadro 500m but I thought that it was worth a try.

If the major slowdown for you is exporting images with DeepPRIME or DeepPRIME XD applied, PhotoLab is not making any use of your GPU because it is not up to the task.


I tried to render a file with the gpu disabled in the preference. Cpu utilisation while rendering went from 5~13% to being pegged at 98%, BUT, 20 minutes later and was still not done, I got fed up and closed it.

Then I disabled noise reduction altogether and started rendering again, took about 18 seconds to render the file. Much better, no doubt, but still 3 time slower than C1 which had noise reduction applied.

Very bizzare.

On top of that, every time I touch a slider in PL, I get the hour glass thing, then the hour glass stop but it take even longer before the image update. With or without the gpu enabled.

Tried with GPU disabled, 20 minutes later I was still waiting for that file with CPU pegged at 98%.

With GPU enabled it took a bit over 6 minutes to spew that file, with CPU utilisation at 5~13%.

I don’t know what’s going on but it’s bizarre, I’ve never seen software behave like this.

Tried the hack. While it did change what I was seeing in Windows performance monitor, GPU utilisation went to burst of 100% for example, it changed nothing to the actual performance of the software, still completely unusable. Thanks anyway.

How long does it take to export if you do not have DeepPRIME or DeepPRIME XD selected? You may not be using any labor intensive processes in C1 that utilize the GPU which is is why processing is so much quicker.


1 Like

Hi there,

According to what you have posted, it seems that your laptop can’t handle the needed workload.
Looking on the web, your computer is close to 8yrs old and the GPU is even older.
Having said that I was curious, and I compared your CPU against a middle of the range AMD CPU (Ryzen 7, 3700X, which was released about 3.5yrs ago).
The difference is huge (BTW I currently have this CPU with an Nvidia RTX 3070 and my PC runs very well everything I throw at it, PL6 included…).


PS/ if you want to have a look at the comparison, it’s here:

PS2/ I have also compared the RTX 3070 (a middle of the range card, 2yrs old now) with the Quadro 500m, and the 3070 is ranked as 1193% faster: NVIDIA Quadro M500M Specs | TechPowerUp GPU Database

With noise reduction completely disabled I’m looking at 18 seconds render time.

In C1 the same file edited the same way took 6 seconds to render, 3 time less AND with noise reduction applied.

Also, every thing I touch in PL is jittery and sluggish; the only program that behave this way on this machine.

It can, marvelously, just not with Photolab apparently.

I use CaptureOne, Luminar, Affinity and even do video editing using Vegas or Resolve with no issues. In fact I can render a 5 minutes 1080p video in less time than what it take to render a jpeg in Photolab, which is bizzare.

If this machine gave me problems across the board, I’d get a new one. But it just ain’t the case.

Out of curiosity, what version of Capture one are you using? Do not equate Capture one’s noise processing with PhotoLab’s DeepPRIME and DeepPRIME XD. It is much more like PhotoLab’s HQ NR which only adds a second or two to processing time. The fact that you say your response is jittery implies you have some preference settings turned on that are not intended for use on older and slower machines. . One of them effects all the sliders and it’s use is only intended for machines that are up to the task. The name of the preference setting escapes me for the moment, but I’m sure others can tell you what it is.