Impossible to open DxO Lab from LR CC using the external module - MAC version

I am using DxO PhotoLab V1.2.0 Build74 and LR CC V7.5

I get the following error message when trying to open Lab from LR using, as always, the external module LR procedure


DxO Photo Lab modules are installed and considered to be active. Look at the dump

DxO modules are installed in //Library/Application Support/Adobe/Lightroom/Modules
They are named as follow: dxo-exporter-dpl1.lrpligin and dxo-importer-dpl1.plugin

I did’nt got any upgrade of one of the soft. Creating a new LR catalogu doesn’t solve the problem.
I suppose that DxO Modules are creating this situation!
Can you check this?



The latest Photolab version is 1.2.1 and this issue should be fixed on it.
Can you try to upgrade and check if you still facing this problem?

Thanks for your fast answer.
There is no upgrade regarding Lab
I tried to reload the module using the LR Module procedure and it doesn’t give any result.

Don’t you have the new plugin modules already?

Hi Michel,

for another reason, I’ve checked updates to PL1, and from PL it said there was no update available.
To be sure that I had the right version, I’ve gone to my account, and download again the program from there.
And now on Mac I’m with v1.2.2 build 81.

So perhaps, this may solve your problem.


I have the same/similar problem, no modules in lightroom since the update to v1.2.2
Where can I get the new modules?

Hello Patrick,
Thanks for your reaction. But, I wonder where you got this Lab version.
You mention “my account” which one? the main account like this one?
So from where did you download this latest version?

Yes, it’s there.
For each product that you have, there are “Liens d’installation” for Windows ans Mac.

Hello Brainois,

It is strange that you don’t see the Update message ?
If you go in the Menu [Dxo Photo Lab/Check for update] nothing appears ?



Yes, that’s strange.
Within PL1, I searched for update, and the message was that no update was available.
Then I go to shop site, and download to check and see that after installation I have a new release.

Hello PAt,

No update message
Here is what I get when checking for update

And going to the shop site I see this on the screen
!! Image edited by moderator = personal license displayed !!

Finaly cliking on the “blue” button I get this

That gives me after loading the same Lab version 1.2.0 Build 74 that is already intalled on my computer.

Suggestion PAt: Is it possible to get a down loading addres for that version???

So well Brainois, I think I have a clue, actually you use an old EA of PL1.
the way to update EA is different than Official release.
I update the EA channel to take the Official release, now if you try to update you will gate last version
Anyway I don’t understand why using the shop you don’t retrieve the right one

Tell me if the update is ok on your side.


Yes PAt, I believe I can do this.
Did you put this last release there?:
Or do you have an other web address?

Please use de the Check for Update Menu in PL1
It must work now :slight_smile:

Hello PAt,
Finally before getting your last message, I did the following and it worked.

  • Download PL !! Link edited by moderator !!
  • Install a second occurance of PL V.1.2.0 Build 74
  • Open it. And finally got autmatically the standard message informing for a new PL version
  • Download and install this new version
  • And, oh pleasure, I got the PL V2.2 Build81

Thanks for your reactivity and your help

Then after opening LRCC I got the standard message informing that there was a new PL plugin to install

And, Everything is back again and work correctly as it had to

SUPER :slight_smile: