Import IPTC location fields from Lightroom

Hi All,
Does Photolab import IPTC location fields from raw files from Lightroom? I know PL imports these fields from jpgs or tiffs exported from LR, but I can’t get it to read from raw files that have associated XMPs.

Most metadata is placed in XMP sidecar files, not in the RAW files themselves. Check the preferences for Lightroom to make sure metadata is being written to those sidecars. Then PL will read whatever is in those sidecars.

In the PL6 settings must be configured to import the data from the XMP sidecar


Thank you. My Lightroom automatically writes xmp files but Photolab is not reading them. Even if I manually tells PL to “Read Metadata”. Still doesn’t work. It only reads these IPTC fields from exported TIFF or JPEG files.

Is the check box checked ?

Yes, this box is checked.

Have you tried with another software?
Are you sure LR written the XMP correctly?
You can share one of your files so that we try.

Hi Franky
It’s really weird.
The same problem occurs with ON1 but not with all files. But with PL6, this happens 100% of the time.
Anyway, I’m attaching the XMP file and screenshots of the IPTC fields displayed in LR, ON1 and PL6. In this particular photo, the IPTC Image location info is displayed in ON1, but not in PL6. Thanks!
P1001444.xmp (333.6 KB)

I opened your file and if I’m not mistaken, the IPTCs are not in this XMP file.

The way I use LR to add locations is by dragging the pictures to the map location (in the map view). Then, the IPTC is automatically filled out in LR that suppose to update the respective XMP file.
In this case, ON1 was able to read, but not PL6. Would this be a LR bug?

I can confirm there are no IPTC tags in your XMP file

But how the IPTC file is populated in LR? And even if I click write Save Metadata to File, the IPTC is not saved into the XMP.

I don’t know LR but there is undoubtedly a parameter to record the IPTC in the XMP.
I’m surprised that ON1 finds them.
What is the format of the file having for “companion” this XMP file?

It’s an RW2 Panasonic G9 file

From what I found on the net, LR and probably on1 generates the location according to the GPS data.
This is probably why ON1 filled the IPTC automatically.

In that case, since Lightroom obviously isn’t writing the IPTC to the XMP file, there is no way for PL to know what it is.

Found the solution. It’s the way LR identifies the location, country, city, etc. In LR, if you drag the pictures to the spot you want in the Map module, LR is going to assign the coordinates and fill out the IPTC location fields with suggestions from Google. In this case, the IPTC location fields will be in italic characters. But they are only written into the XMP files once these suggestions are “confirmed” and this requires the user to type the information in the IPTC fields. So, for instance, if the country “Chile” is written in italic and if you agree with this suggestion, you need to type “Chile” in the country field. Then the italic font goes away. If you only use LR, you don’t need to confirm the locations because the program works fine with the suggestions only, but if you want to use this IPTC info in other programs such as PL6 you need to confirm the info in order to write them into the xmp files. The link below describes a solution for this…the plug-in works well. I hope this helps others facing the same issue.

Good News: DPL 6.3.0 on Mac does as epected: It imports IPTC location data, if they have been written to the .xmp file by Lightroom Classic.

Even though adding the location tags in LrC manually is annoying, the tags are used and written to the .xmp file. DPL then shows the “metadata sync” badge (I set DPL to not automatically sync metadata) and imports the GPS coordinates in the Exif palette and the location details in the IPTC - Image palette as shown in the screenshot above.

The annoying part is to have to type the tag values, but that is something that Adobe has set up to keep their users busy :wink: