Images Not Exporting to Nik Collection

I have DXO PL4 Elite with the latest FP and VP. I had Nik Collection 2. This combination worked perfectly fine. I recently updated to Nik Collection 4. Now I am unable to export PL images to Nik. I select the Export to Nik and the bar goes green and then red. The error messages states “Could not save image”. It does not matter which Nik Collection app I select, the outcome is the same. This is my second issue with DXO since the latest updates. I was always a big fan but am wavering…

In your Documents folder there should be a folder where PhotoLab 4 stores its log files. I would look in the log file that was open at the time of the problem, to see if it contains a better explanation of the cause. (I wish software would give more helpful error reports without having to do this, but that’s an industry-wide problem.)

It’s also worth trying to reinstall the latest PL4 and Nik 4, if you haven’t already.

Solved the problem. MS Windows Defender was blocking DXO related programs. I had to allow access for two programs. See attched.