Image size limitation for FilmPack

Hi All,

I am experiencing a size photo limitation when I try to apply a FilmPack setting.
For a very large photo (panoramic), the filter is not applied. The plugin opens, the settings are correctly displayed, but when applying to the photo and going back to Photoshop, the filter is not applied.
If I reduce the size of the photo, the plugin works as expected.
It seems that a size of 20,000 pixels on one side represents a problem for the plugin.

Have you experienced such a problem?

Thank you

Best Regards,


I don’t have Photoshop but, working with a 21.5k pixel TIFF panorama, the file is correctly saved here. Maybe it’s more to do with Photoshop?

Hi Joanna,
Maybe. I tried also with Affinity Photo. Same behavior as in Photoshop.
Are you working with the standalone version? I didn’t try yet.

If I could find how to install the plugin into Affinity, I could give it a try. Any ideas?

Maybe this helps:

Nope. I don’t have enough licences to do another install and, if I add it manually, Affinity just blows up when I attempt to launch the module

DxO don’t officially support Affinity so, if I were you, I’d just use the standalone version :wink:

I exported the photo in a TIFF-file and opened it in the standalone version of FilmPack. It worked well.
It may be a limitation of the plugin version.