I upgraded to Photolab 5.1 - Now I can't export images to disk

Win 10. I upgraded from 5.0 to 5.1. Now, I’m not able to export any file to Disk in any format. Error is “Cannot open file for writing”. I’ve tried uninstalling and re-installing but still no go. Has anybody else had this problem?

Welcome to the forums @mcaicedo
I remember someone reporting this in v3 or 4… but then realized it was something they were doing…

Oh yes. I remember now… Are you trying to export the images to the same directory?

Surely you need to add:
…and NOT changing the file name?

I always export (from DxO) to the same folder and have no problems but my exports always have a different name to the source / edited file.

Or could it be that @mcaicedo is describing the bug that PL5 introduced that means if you open a file in Photoshop from PL5, make some changes in PS then you cannot save those changes in PS until you close PL5? As discussed in this thread:

1 Like

@mcaicedo Sorry, given this was your first post and there was only mention if PL 5 > 5.1 upgrade, I didn’t know you had been using PL for any length of time.

I’ve tested export since upgrading to 5.1 and am not having any issues. It sounds like what you are seeing could be related to permissions? Or, as @stuck mentioned a file is locked or in use, but your workflow was not provided so only another guess based on limited information.

Opening a ticket with support and posting your log files might help.

1 Like

Hello everyone! Thank you for the responses and welcome.

Thank you @shadowsports for your suggestion. I was thinking permissions too, and so reading your response jogged something in my head that it could also be one other thing that prevents one from writing to the file system…the anti-virus program. Sure, enough, I disabled AVAST for 10 minutes and voila, I can export again.

What threw me off initially was that PL 5.0 worked perfectly and PL 4.0 is still working. :smile: I guess I can cancel that ticket I opened.

Thanks again for taking the time to respond.


Is there a way of excluding pl from it?

I had the same issue with Win10 Controlled Folder Access (Windows Security/Virus & threat protection/Ransomeware protection/Controlled folder access). After many stumbles using it I finally disabled CFA.

Yes, there’s an option in the anti-virus program you can configure when what it thinks is an unwanted program tries to access a resource. This option defaults to automatically deal with it, and so it did. I had to change the option to “Ask what to do” instead. The next time I tried to export a file, an Avast message popped up asking me if I wanted to allow the Photolab.ProcessingCore.exe to access. I clicked “allow” and everything is good now. I assume other anti-virus programs can also white-list and app if necessary.


Going off at a tangent here, is there a particular reason why you (presumably pay money to) use AVAST over the (free) anti-virus application (MS Defender) built in to Win 10?

Avast like many others has a free offering which affords an additional layer of protection.

I have never used Avast, but have encountered it on user’s systems over the years. I think AVG is a better product personally.

*Plain vanilla Windows Security here.

Plain macOS, no AV required here :stuck_out_tongue_winking_eye: