I guess I give up

I have been using PL, and Optics Pro before it, for a long time, and I have been asking Dxo to fix one single processing failure all that time. If I use the Export To Application functionality PL sends a processed image to an external app, in my case Photoshop, where I can do work I can not do in PL. I then save it using the original file name for further processing in PL and PL will not re-read the returned image and display it as it is after the change in PS.

Every other workflow tool I use handles this properly. I began filing change requests years ago and each time there is a new release I check to see if this has been fixed, and every time it has not. I checked again with PL2 and, again, it is not fixed.

I guess I just give up on PL and will use another workflow tool that can handle a simple external edit change.


correct me if i’m wrong here but, PL read the sidecar and adjust the image base on that sidecar not saved from another app, if you remove that sidecar PL will show you the final edit saved from Ps and not what was done before.

PhotoLab keeps the changes in both the catalog and in the sidecar files. Removing the sidecar file will not force PL to update the image based on changes made externally to the application. In fact I have tried completely stopping the creation of the sidecar files and it has had no effect. Even if manually removing the sidecar file fixed the problem it would mean opening Finder for every such image and manually removing the sidecar and that is too much unnecessary work when I am processing hundreds of images.

I have filed several change requests, all of which were apparently ignored, although I did once get a response from the Optics Pro people telling me to not export an image to an external editor and then save it back to the original image. Apparently they did not want to have to process externally edited images in PL, although I do not know why. There was a comment on this forum from the staff that they were going to fix this, but they have not as of yet and I have been waiting for this fix for perhaps 4 or 5 years.

I really like this software and it has been my go-to workflow tool for a long time but I have just gotten truly discouraged by trying to get them to implement something that every other workflow tool does without an issue. I worry that this post may sound like a rant, but it is not intended that way. I am just very sad about feeling forced to change to some other software because I can not get Dxo to make a simple change.

I’m a little confused by your posts. You refer to sidecar files, but those are only used for raw images, not when you export tiffs or jpegs which are self contained. When you export an image to Ps you are doing so as a Tiff or jpeg. When you are finished editing the image in Ps are you saving it before exiting? When you go back to PhotoLab is the tiff file not visible? You can’t update raw side car files with additional edits across applications. PhotoLab’s sidecar files are not even the same name or format as Camera raw’s XMP sidecars. From your other posts its sounds like when you go back to PhotoLab you are expecting to see the changes you made in Ps in your raw images. That’s not how it works, Perhaps I’m misunderstanding what you are attempting to do.



Sorry I meant saved by PL, not saved by Ps.

I don’t have PS any more, but tried various sequences using GraphicConverter. The .tif exported to application is always suffixed eg _DSC0374.NEF becomes _DSC0374_open with.tif. This appears and opens in PL perfectly normally and if worked on, gets a _DSC0374_open with_openwith.tif.dop added. If altered in GC and then a Save forced, there is a dialogue “_DSC0374_open with.tif already exists etc” so you can either save it with 01 further suffix or overwrite with same file name…or Save as: _DSC0374.tif, which then also appears in PL. You can’t save it as _DSC0374.nef as you are told it isn’t a nef. It is pretty near impossible to save it under ‘original file name’ except altering it in Finder and over-ruling suggestion of inappropriate name.

If PS doesn’t have normal MacOS protection and will save something as a .nef that isn’t one, then it is PS fault, not PL. Likewise a PS .tif may in fact retain layer information (seem to recall such), but then it is not going to be any use for an application that doesn’t use layers, or indeed a real .tif at all.

Perhaps my post was not clear. Here is the sequence:

  1. Edit a raw image in PL. In my case this is an ORF or CR2, but the specific raw suffix does not matter,
  2. Export to application. The application you export to does not matter. I use Photoshop, Affinity Photo or PhotoLine. PL exports a tiff to the editor, not a raw image,
  3. Edit the tiff in the editor and, when finished, Save it to over-write the original tiff. That tiff was created to send the image to the editor so there is no reason to create another image file when it is edited,
  4. Open the tiff in PL and you will see that it is almost never updated to show the changes.


  1. I am not talking about writing the changed image as a raw NEF, CR2, ORF or any other raw format.
  2. Using a Save As with a different name creates an image file that PL will display with the changes, but there is no reason I see that I have to clutter my system with extra images. I created the tiff to edit it in a pixel editor and then continue the editing back in PL. I should be able to use the same file, just as I can in Lightroom, CaptureOne, AlienSkin’s Exposure X4 and every other single workflow tool I have tried.

> You can’t save it as _DSC0374.nef as you are told it isn’t a nef. It is pretty near impossible to save it under ‘original file name’ except altering it in Finder and over-ruling suggestion of inappropriate name.

I am not trying to do that. I am trying to over-write the tiff, and I should be able to do that. Please re-read my post.

Actually that is incorrect. PL will produce a sidecar file for any image file, raw, tiff or jpg, that is edited.

Of course. I would have no issue if I were not saving the changes.

Yes, the tiff file is visible, but PL does not display the changes I made in Photoshop (or Affinity Photo or PhotoLine or, for that matter, in the Topaz Studio editor), and that is the problem.

No. I am expecting to see the changes I made in the exported tiff, not in the raw images.

I edit a raw image in PL, export it to PS as a tiff, make changes to the tiff in PS, save it back to the same tiff file with the PS changes and when I select that tiff file back in PL I expect to see the PS changes. I do not, and thus I can not continue to edit the tiff image in PL.

Consider this. I have an image that has some lens flare or other issue I can not address in PL. Perhaps I wish to replace a sky, or add a texture to the image. Perhaps I wish to correct some perspective issue that I can not do natively in PL. I export the raw image, with the PL changes, as a tiff to PL where I correct the issue that needed fixing. I then have a tiff with the PL edits and the PS edits, and I save that back to the original tiff file that was sent to PS. When I click on that image to do further PL editing on it I do not see the changes I made in PS, and I should.

I am not sure why everyone thinks I want to see the changes in the raw image. I edited a tiff in PS and I expect to see the PS changes in that tiff when I further edit it in PL. If that was unclear in my post I apologize, but when I referred to the original image I meant the original tiff created by PL and sent to PS.

i am not very good in layer in pse13( i never use it so i s*ck in that bigtime) but i did:
1 export to pse editer => creates a 16bit tiff file. in same folder as the rawfile.
2 did somefooling around it asked to go to 8bit.
3 click on x, question pops up if i want to safe first in folder thisandthat. answer yes.
3a asking overwrite because file exist => yes. (file becomes bigger because of implenting layers)
4 DxO PL opens:
thumbnails of tiff looks as the ruined file i made in pse13
same as tiff on edit screen:
did it twice. original tiff made by dxo is overwritten.

Did i what you said you can’t? Or did i misunderstood you?

You did not misunderstand me. You did what I normally do, and you got the changed image back in PhotoLab. It has been my experience over many years that the process works every once in a while, but does not work most of the time and by “most of the time” I generally mean every image after the first or second try in a processing session. That is, if I start an editing session and send 20 photos to Photoshop I may get one or two where the saved image shows up correctly back in PL, but all of the rest fail.

Here are 2 screen recordings. In the first I send a tiff to Photoshop, crop it, save it back to the original tiff file and then check it in PhotoLab. In the second I do the same, but also add a layer to the saved file. As you can see in the recording the cropped image does not show back up in PhotoLab.

These were efforts 2 and 3 in a sequence. I did not record effort 1, and it worked with the cropped image showing up in PhotoLab. Sometimes the first effort works, sometimes not, but almost all subsequent efforts fail.


One more thing to mention. If I exit PhotoLab, change the name of the folder containing the edited images, restart PhotoLab and switch to the new folder name the changes show up. They are there, but I can not find a way to force PhotoLab to re-read the images to show the changes other than changing the folder name or deleting the PL database and dop files. Then PL re-reads all of the images and I can see the changes, but short of that it is hit-and-miss with that really meaning “an occasional hit and all the rest misses”.

I would ask OXIDant, who went to so much trouble to test this, to do it a second and third time with different images and post back his results.

I believe the issue is with the file handling of PL in MacOS. It is not clear when PL notices a file change and when it just uses cached data. Moreover, as complained elsewhere, you can’t force to reread a directory to work around the issue. Sometimes changing directories back and forth helps. But this is time consuming and doesn’t always help.

I also see similar issues even with new files (TIFF) in the directory where PL looks at are not handled correctly when they are created. Sometimes PL seems to pick them up before they are fully written and complains they can’t be rendered. A rename on the filesystem fixes the issue because then PL sees them as new files.

A simple “refresh” option and PL only scanning the directory again for changes when it gets the focus back would improve the situation.

I did it with just one image. on win10.
So indeed maybe its a Mac issue.
Did you make a ticket to support as a error?
If you stil like to test more images in one row back and forward i will later this week.

I did include your required situation; ie when saving it in the other application, you choose ‘overwrite’. It seems to work OK for me. However, as Christian says, the older file of same name may be hanging around in a cache for a while. It strikes me you are asking for trouble putting two different files with the same name into the system. It used to be useful to keep the original exported .tif for the simple reason it took longer to re-export it than it does now. With the possible exception of when doing a long stamp/clone operation in another application, what I need to do elsewhere usually only takes seconds.

Before i got used to export to application, i just exported the ones who needed extra in a different folder called “TIFFoutput” And those bunch i opend in the application which i needed. (closed the raw developer for memorycach reasons. )
Do my thing in tiff work and export back in jpeg or tiff (make a folder if i need to work again on tiff.)
So i keep al stages on disk, and that is my main struggle in this form. diskspace, cluttering of almost similair images.

So i use mostly export to application. There is inbetween:
Export to a folder “worktiff” out dxo.
open the exported in Ps, work on that, save back in the subfolder inside work tiff “done”
when satisfied, cut and paste tiff’s in dxo workfolder. open dxo there they are.
clean workfolder after completion to save disk space.

This methode is very usefull when you do large amount of work, just export the one you want to do more outside dxo get on the new one and so one, after a bunch get back to the tiffs and open de app you need.
(one thing remember why you exported a tiff. that’s the thing. atleast for me…) Some times there go days before i start on stage 2. :smiley:

PS - actually it can’t matter as there are lots of image files with same name in the system as I get through 10k images in about a year and have used Nikons for about 10 years. It can only be 2 very close together in time that the software and/or OS has in cache before permanent filing. Suppose you set PL cache at zero?

Environment: 27in iMac 13,2, macOS Sierra, 24GB Ram, DPL

I tried to reproduce your findings. This is what I did:

  1. selected a few images and customised them
  2. Export To Application Photoshop CC2019 and got a crash
  3. restarted DPL, selected a few images and customised them
  4. exported to Photoshop CC2018 (no crash this time) -> 5 out of 6 processed JPGs displayed in DPL
  5. PS opened
  6. applied NIK silver effex to all images
  7. saved images as TIFF
  8. brought DPL to the front again, but the results of steps 6 and 7 did not show
  9. switched to the photo library tab and selected a different folder (containing images)
  10. selected the original folder from step 1 again
  11. all images showed up: the original CR2s, the JPGs from step 1 and the TIFFs from step 7


  1. All in all, the round trip seems to work with a few quirks (see step 4), I’d not call it elegant though.
  2. There is some room for improvement of stability regarding a) version interoperability and b) against user manipulations while DPL is processing.
1 Like

This has been a problem on the Mac for years and I always assumed that either PL (and OP before it) did not place a “watch” on the folder or that it was badly written, so PL does not know when an image has changed and does not do a re-read. This would be more forgivable for me if it were not the case that every other workflow tool I use on the Mac has solved this problem.

And I completely agree that a simple “refresh” command that forced PL to re-read the folder would solve the problem. I believe such a command exists on the Windows version, but not on the Mac. I have been filing reports about this for years now, and either no one at Dxo cares or no one wants to fix it, and hence my frustration. I have used this software for a long time, but I can not get a simple, but very annoying, issue resolved.

Renaming the folder always works as PL is forced to read it and display the images, but I believe that is asking too much of a user.

There is, of course, one more explanation as to why PL fails to do this work. It could be that the designers just do not want users to be processing tiff or jpg files with PL. Perhaps they only want to be processing raws because of the quality of the changes, but that seems to me to be ignoring reality.

Yes. Repeatedly.

Usually the tickets are ignored but one response I got back from support was basically “Don’t to that”. That is, don’t try to continue editing an image after sending it to an external editor. That kind of comment might be easier to understand if PL could fix some of these issues, but it can not, and neither can any other workflow tool. For what I need to do to these images I need a pixel editor.

I do not understand your comment. I am not keeping two different files with the same name in the system. I am over-writing the original tiff with the revised tiff, so there is only one file with that name and path in the system.

Or perhaps I am misunderstanding your comment?

Your processing seems to create jpgs for PS, and those images are then saved as tiffs. That is, you end up with 3 images for each processing raw - the original raw, the original jpg sent to PS and the tiff saved from PS. In no case are you over-writing an image and I know this process works as my work-around was the following:

  1. edit raw in PL,
  2. send tiff to PS,
  3. edit tiff in PS,
  4. save tiff WITH A DIFFERENT NAME,
  5. open newly named tiff in PL and continue processing.

This workflow takes care of the issue because each step creates a different image file, as your workflow does, but it also has the burden of creating extra images and taking up extra space on my ssd, which has only limited space to begin with. A tiff file may easily take up close to 100 MB and I am often processing literally hundreds of these, so it is much more efficient for me to save the tiff back to the same image file as was loaded into PS for the editing.

Personally I can see no reason that PL should not understand that a tiff image has been updated and saved back to the same name by an external pixel editor, and thus I do not understand why PL refuses to re-read the image file and display the changes. As I have repeatedly pointed out every other workflow tool I have ever used does this - Lightroom, CaptureOne, ACDSee’s PhotoStudio, AlienSkin’s Exposure X3/X4, even Corel’s AfterShot Pro.

I really don’t think I am asking much here, only that PL understand that an image has been changed and display the changes. Yes, I can get around the problem by creating extra images as you have done and as I did for years in an attempt to continue using PhotoLab (and Optics Pro before it), but I end up filling up my limited space with unnecessary and unneeded large edited tiff images