How to find pictures without keywords?

Hi, is there any possibility in DXO-PL to find pictures that don’t have keywords so I can tag them?

There is no magic. You’re just going to have to trawl through them.

Well, “just” through several thousand pictures.

I just tried to setup a macOS Spotlight search to do the same thing and could not find a way to do it.

There might be a syntax for ExifTool that you could use to list files on the command line, but the problem is specifying it to exclude any unwanted files (like DOPs) and folders.

I’ve been looking for that way too. But the problem is that an empty keyword means that the keyword tag just doesn’t exist. It could be done within a program.
Nevertheless it could be useful.


I just worked out how to use ExifTool to list all files that do not contain keywords…

exiftool -if ‘not defined $keywords’ -r -filename .

Use double quotes instead of single quotes if you are on Windows.

Doesn’t work with me.


exiftool -if ‘not defined $keywords’ -r -filename .
For the actual directory.


I think the same problem as you. The '* . * ’ is not shown at the end of the command.


Which bit doesn’t work? The double quotes on Windows? Because your example is identical to mine for Mac

Oh, do you mean it wasn’t obvious from my example to type the ‘.’ at the end?

The file selection.

exiftool -if ‘not defined $keywords’ -r -filename *.nef in my case
I did put an space between the asterix and the point.
But it works.


Hmmm. I didn’t put asterisks into my command because they are not necessary. The dot on its own automatically means all files in the directory. And asterisks confuse the Markdown interpreter into thinking you want to italicise the dot.

But, essentially, it would seem we are agreed on the syntax.

The above does not work in zsh. I have to use this instead:

exiftool -if ‘not defined $keywords’ -r -filename *.cr2

Note the single quote marks. I had to use straight ones, not the slanted ones.
Attention: The forum software misinterprets the single quote marks when the message is displayed. Therefore, copy-paste from my input will not be helpful…
Straight marks are two keys left of the “L” key on an US keyboard layout on Mac.
Note that you might need to search *.xmp instead of the *.cr2 I used in my test. A dot (instead of any file specifics) will suffice, if you want to have all files searched…

Funny. Graphic Converter can (amongst a lot of other stuff PL users can only dream of) filter for im ages without keywords. CaptureOne can create an intelligent album with all images “keyword = none” (where none is simply an empty field); Aperture can do the same, btw. But as long as PL has so limited DAM possibilities I would not expect a possibility to show images without keywords, that app was never programmed with something like that in mind.

Most other tools have the possiblitiy to do such a search, e.g. Lightroom, digikam or XnViewMP. I can of course use another tool but I wanted to know if it is possible in PL. Technically, a search for pictures in a database that have an empty keyword field shouldn’t be too difficult to implement.

1 Like

Try it.
If the metadata window has a field for keywords, then that is most likely a fixed field that will be filled with either the keywords or with nothing. That’s something else as active searching for empty keywords. Keywords is not a predefined field in the metadata.
The question is do these programs allow you to search for the absence of a keyword tag or are they just showing the keyword tag is missing? I don’t have those programs.


What specific search parameters would you like to see implemented to find images for which there are no keywords?


Something like that (“Ohne Stichwörter” means without keywords). This is Lightroom 5. I used it now to assign keywords to pictures without keywords.

However, I observed that PL doesn’t always create an XMP, although the box in the preferences is ticked. Therefore, I will manage my pictures with Lightroom as long as this bug is corrected and more functions for managing images are implemented.

I’m afraid it’s not a bug @me_here PL is far away from the comfortable search of intelligent folders - if it’s not in the filter options, you can only search for what is existing.

The bug is that PL doesn’t always write a XMP, although e.g. a keyword was assigned. It isn’t reliable in this respect.

You did get the images with no keywords. And that’s what you wanted. However it isn’t the result of an active search, it’s the result of an indexing on keywords.
Shouldn’t be difficult to implement that in PL.