How do I even get started?

OK, I have downloaded the free trial of PL7. I am using a Mac with Apple Silicon and the latest OS (I can’t use the Mac tag for this posting, apparently!). The first thing that comes up is a window titled “DxO Hub”. It says “Push your photography gear to the limit with DxO Optics Modules”. So I click the “Learn More” button . . . and get “Oops! That page can’t be found”. Not a very good start. Never mind, I will play around . . . DxO opens with the PhotoLibrary tab, which shows a list of all my folders. So . . . let me see if I can get an image and see what I can do with it. But when I go to the Pictures folder, DxO says “This folder does not contain any image”. Hmmm . . . maybe it can’t access anything inside Apple’s Photo library. Let’s take a look at some JPEG files I have on my desktop . . . . nope, they are not visible either. Perhaps it ignores plain JPEG files and will only recognize RAW file . . . so I get a RAW image, copy it to my Desktop . . . but DxO says there are no images there either. I peruse the Forum, and find that on a Mac I have to go to System Settings > Privacy & Security > Files and Folders > DxO PhotoLab 7 and allow it to access files and folders . . . . so I do that . . . it would have been nice to have been told that from the get go. But even after restarting PL7 three times I still cannot see the images that are on my Desktop or in my Photos library. Any advice? This looks like a great piece of software but so far the implementation is not too great!

Welcome to the User Forum, Allioua

There are many “happy” PL-on-Mac users here on the forum … I’ll signal to a couple of them to give you a hand … @platypus & @Joanna

John M (on Win)

Try giving PhotoLab full access. That’s what I set on macOS Mojave and the other volumes with Mojave, Ventura and Sonoma. I can attach a screen capture later on if you think it will help.

Also check access privileges of the places you try to read from, just in case you might have changed them and forgot about it.

Apple has tightened security over the last few versions and while it’s okay to do that, it can get in the way of ease if use. You can reset access privileges in like so:
tccutil Man Page - macOS - Note that each app should then ask for access again, which can be annoying at times…but necessary for better control of what we allow those apps to see.

1 Like

Thanks. I have given PhotoLab Full Disk Access - it will now see photos on the Desktop, but still not in the photo library. However, when I go to System Settings>Privacy & Security>Photos, PhotoLab is not listed among the apps that can be allowed to access photos, and I can’t see any way to add it. It looks as if access privileges are OK - at least the Info window for Photos says I have read and write access to the library. I don’t really understand the information in the link you gave, and am not comfortable trying to mess around with Terminal. (But I am glad to see that the broken link from the Hub splash screen has been fixed!)

PL will not be able to access photos in the library managed be the Mac photos app. Nor will any other application apart from Photos.
You need to point PL to the location containing your raw files, or go there in Finder and right click and choose "open in … "

Thanks! I wish DxO advised about that :slight_smile:

I am not a Mac user, but @jeffholdgate indicated that no application apart from Photos can access images from that applications proprietary library. If he is correct, why would you assume that it is DxO’s responsibility to inform you that you can’t access that library from PhotoLab.?


It may not be their responsibility, but if they want people to use their software it is good customer relations to tell them how to use it.

They don’t need to because there is no such restriction. But read further for why you shouldn’t use Photos and PhotoLab on the same images.

In fact, Mark, you can access the original image files from the Photos library.

When you see an app in Finder, it is not a single file but is known as an Application Bundle. In other words, it is a folder that has been marked to be recognised by the OS as containing the executable file plus most of what is needed to support it. So uninstalling an app is as simple as deleting the .app bundle.

In the case of the Photos library, it is also just a bundle, with a hierarchy of folders and files inside it.

Here is my default library…

As you can see, it is just a hierarchy of folders and files but one of them is called “originals” and this is where Photos stores the original files that you add via the Photos app.

In order to access this from PhotoLab, you need to switch on the preference to see bundles…

Then you can navigate to the appropriate originals folder in PhotoLab…

But let me warn you that it is a very bad idea to store your images in Photos and edit them in PhotoLab.

When PhotoLab edits files, it adds a DOP sidecar in the same folder as the original file and this can possibly affect Photos management.

Also, Photos is an image editor and maintains its own database of adjustments, which cannot be accessed from PhotoLab - and the same applies to trying to access the PhotoLab database or DOP files from Photos. In a word - DON’T.

If you have already started storing images in Photos, you need to transfer the original files to an ordinary folder hierarchy under your Pictures folder in Finder and do not continue to edit them in Photos.

Yes, you will lose any work you have done in Photos but the better results you will get from PhotoLab will be worth the effort.

@Allioua don’t hesitate to ask further if what I have said is not clear.

1 Like

Joanna, thank you SO much for all this information! Much appreciated! Perhaps DxO should hire you as a Mac advisor!

Thanks for setting me straight on this, I had no idea that that was possible.

FWIW, in my experience helping my wife get set up to edit her JPG images only in Adobe Lightroom Classic with a new MacBook, we had the exact same problem. These security restrictions are set by Apple, not DxO or Adobe, and to be fair, they’re not a bad idea. Apple just runs a tighter ship in its OS; it’s very annoying at times, but probably safer.

Assuming this isn’t covered in the user manual–I didn’t check–yes, DxO and Adobe could do a better job helping Mac users get started, but what I do when I encounter issues like this with the Mac OS which I don’t know as well as Windows is websearch the question or error message, and I normally find the answer and resolve the issue very quickly. Of course people here can advise you even more precisely, but the faster answer can be found in a general websearch, often. It worked with her permissions issue with Lightroom.

Once you set your Apple OS correctly, you won’t have this issue anymore on that Mac, with DxO PL, anyway.