How can I add multiple photos to Lightbox in one action?

I’m new to DXO PureRAW and just trying out the trial version. I’m a Windows 11 user.

I’m attempting to add photos to Lightbox. I have a FujiFilm X-T5 connect to my PC via USB. My actions:

  • I click the “Add photos to Lightbox” dialog and navigate to the X-T5>External Memory>SLOT 1>DCIM>100_FUJI folder on the SD card in the camera.
  • I select all the images and click “Add photos”.

This gives me an error message “Cannot open multiple files from this location”. If I select a single image however it works.

How can I add multiple photos to Lightbox in one action?

Welcome to the forum @freebirduk

Try this: Copy the image files to your computer’s drive before attempting to add files to the lightbox.

Thanks for responding. I’ve actually done that and it works fine. However I’m trying to make my workflow as tight as possible. I can’t understand why I can copy a single image to the lightbox, I can select multiple images but I can’t copy multiple images. Is this just an odd constraint in PureRAW or is there something I can tweak to make it work?

…dragging images to the lightbox doesn’t copy anything. Other than that, I always add several images to the lightbox, but I use the respective button/menu instead of drag&drop. It usually takes two tries to select all, but then, the selection shows up in the lightbox and can be processed.

Thanks platypus. I appreciate that adding images to the Lightbox simply flags them for processing rather than physically copying.

Our experience seems to vary. I’ve tried both drag’n’drop and using the “Add photos to Lightbox” dialog then selecting multiple images. Either way I get the message

Cannot open multiple files from this location. Try selecting a single item instead

I’ve retried many times. I’ve tried just selecting two images. I’ve tried selecting contiguous and non-contiguous images. I always get this error.

I assume this has something to do with the interface with the SD card. It’s odd though that I can copy multiple files directly from the card into a Windows folder and I can import multiple files directly into Lightroom Classic but I can’t route multiple images into PureRAW without first getting them off the card.

Odd indeed…and if it stays as it is, there is nothing else we can do to change it, except the usual things like formatting the card and see if it helps, try a different brand or speed rating etc.

Testing this on my iMac, I found that DPR3 perfectly accepted the three Canon CR2 files I dragged from te SD card to DPR’s window or the DPR icon when DPR was off… :person_shrugging:
Note that the SD card was inserted in the iMac’s SD slot

Problem solved. It turns out that connecting my FujiFilm X-T5 to my PC via USB-C and trying to read from the card directly with PureRAW doesn’t work. However pulling out the card and plugging it in to my PC via a SanDisk reader works fine.

You live and learn.