Help! Can't export finished file to disk

I hope someone can help me please. I am using DXO PL 3, but when I last used it, after the latest update, once I had completed editing a RAW file I clicked on Export to Disk but although the process seemed to be being carried out, at the end there was a red exclamation mark on the image thumb nail, and hovering over it said " Save has failed. Cannot Open file for writing".
I couldn’t get it working so reverted back to DXO PL 2. However I had the same problem. I then uninstalled both PL 2, and 3, then downloded and did a clean install of PL 3. However the same problem exists.
Does anyone have any ideas how I can cure this problem please? I’ve been using DXO for a few years without any problems.
I’m not the best with computers, or editing so please be kind
best wishes and thank you

Hello @waffley and welcome to the forum,

Could you, please, provide us with your logs? You can find them here - %UserProfile%\Documents\DxO PhotoLab 3 logs (please, archive them and attach here).

Thank you,
Svetlana G.

Thank you for your welcome and offer to help!
I’ve found the logs, but I’m afraid I have no idea how to archive them and attach here.
Sorry to be so weak on this subject
Best wishes


Okay, then create a ticket on and you’ll be carefully guided with all the procedures.

Svetlana G.

Sometime it means that the already existing disk file is protected in some way.


Hi Svetlana
I’ve attached the logs as a Zip file. I hope that’s OK. I’m afraid the support suggestions so far aren’t helping, but interestingly they havent asked to see the logs
IDXO PL3 (22 Bytes)


It’s empty - no log files inside your zip.

Svetlana G.

I’m really sorry. I am pretty useless with all things computers! I am now in touch with the support team, and I’m hopeful they can resolve this issue, although it will probably end up being something that I did wrong.
Thank you anyway for trying to help!
Best wishes

1 Like

Hello. If stated in an earlier post, I have missed it. What operating system are you using? Windows or Mac? I am thinking that due to something changing in the operating system, your permissions have been altered. I just switched my Mac to Catalina OS and I ran into the same problem without much of a warning.

To me it feels like the card is locked, and the program tries to save the file to the card!

Check if the lock tab is in the locked position, if it is just push over to the unlocked positioon!

ello. I have the same problem as Waflley.
Unable to export photo after updating to DxO 3.3. A red exclamation mark and a red DxO logo will appear on the photo.
I’ve already uninstalled DxO, reinstalled it and it’s still the same. I use it on an HP notebook with WIN 10.

Hello @turekm,

Please, create a ticket on

Svetlana G.

I’m using Windows!

The times I got that message it was always a warning of the os.

Create a new directory and try to save to that one. See what happens.


Dear @waffley,
Export to disk could be any Drive and path and depends if you chose the “original image folder” or a custom one.

By choosing the original image folder the export will be saved to the same place, for example your SD Card, where the photas are stored. If then, like Tord says, the SD Card is write protected the process fails.
To try you can choose a custom folder, maybe the User\documents directory where you normaly save your Word documents or other stuff.
Or you plug an USB device and try to save with custom folder at this device.

1 Like

Thank you Milan. I too am using a HP laptop and Windows 10, and I seem to be causing the developers a headache, because nobody else has the problem. Perhaps if could do as Svetlana suggests and submit a ticket to the support team then it would back up my findings too.
many thanks for your support

Hi Waffley. My problem is solved by myself. Today everything works for me. I don’t know how it’s possible, I didn’t do anything about it. I wrote for support yesterday, but I don’t need it anymore. So good luck Milan