GPU hardware acceleration in other programs appears to make PureRAW 3 stop processing files


After reformatting my PC I encountered a problem with PureRAW 3 which appears to be related to GPU hardware acceleration.
When it is processing images it appears to stop working once another program that also uses hardware acceleration is running at the same time.
I noticed that it appears to be related to hardware acceleration after I switched to the latest Nvidia studio driver in an attempt to fix the issue. While my system installed the driver, Discord, which was also set to use hardware acceleration, crashed. I restarted processing the RAW files and after that I restarted Discord. Once Discord was fully restarted PureRAW stopped proccessing the files again. It was completely stuck with the remaining time getting longer and longer. GPU utilization in the task manager was at 0%.
After turning off hardware acceleration in Discord and restarting PureRAW 3 everything worked normally.

I am using an Nvidia RTX 4060, a Ryzen 7 5800X and 32gb of RAM. The OS is Windows 11.
In Windows I also turned off hardware accelerated GPU scheduling in an attempt to fix the problem but that did not help.

Before reformatting I did not have this issue at all. Though I am not entirely sure if I disabled hardware acceleration in Discord before installing PureRAW back then.

I am not entirely sure if I should even call this a bug but it might be useful information for others with the same issue.

Have a nice day!

Good find! Maybe this has something to do with it?

I see the same using Win 11/LR13/PR3 on an NVidia 4070 Laptop.

If PR/LR are in the foreground then processing works normally.
If i get bored and toggle to something else then often the processing fails - hangs for ages on whatever image then eventually errors and quits. Sometimes i need to manually kill the task with task manager.

The problem is more noticeable on the highest DeepPrime but thats possibly just because it takes longer so more chance of me flicking away.

On my system it’s pretty much confirmed that the issue is the hardware accelerated GPU scheduling. It’s mainly used for features like DLSS frame generation in games so I just keep it disabled.
It’s exactly the same on my end though. After a couple of inches it stops processing and I need to kill it in the task manager.

Same here with Deep Prime XD, Windows 10 Pro and Geforce RTX 2060 Super. By some testing I found out that the issue only appears for me when using the Lightroom Classic plugin. With the native PureRAW app I could run other GPU using apps simultaneously with no problems.

When I set both Lightroom and PureRAW to CPU only the processing doesn’t hang up. But it’s just too slow that way.

The LRC plugin is very important for my workflow. And the problem wasn’t there from the beginning. I don’t know the exakt day but I would say it worked fine at least until the end of 2024. I think I will have to open a ticket.

Update: deactivating hardware accelerated GPU scheduling in the windows graphics settings seems to have solved the problem for me. Running without hangs now. Processing appears to be a bit slower now. But I could be wrong. Didn’t really test that thoroughly.