GPU Acceleration Disabled on Photoshop v22.1

From the release note of Nik collection 3.3, it claims that it is compatible with photoshop v22.1 (2021). However, after using filter from nik collection e.g Color Efex Pro and go back to photo workspace, GPU acceleration would be disabled. It is working fine on Photoshop v21.2.4 in same environment.

Processor: Intel 10920x
OS: Windows 10 20H2
Display Card: Nvidia RTX3090
Nvidia Driver: Studio Driver 457.30 - 469.89
Photoshop: v22.1 (Problem)
Photoshop: v21.2.4 (Working fine)
Nik collection: v3.3

Submitted ticket to support service, and captured PC log to support, then never has any response since 12/14/2020, it is almost a month, really frustrated as a licensed customer.

Try to disable the CPU integrated graphics card. Photoshop often has problems with 2 cards. In my case, it solved the problem.I

I only got 1 RTX3090 GPU, 10920x processor has no CPU integrated graphics.

Here is the reply by DXO support:
"Thank you for your patience as we worked with Adobe to diagnose your issue further. After a long discussion with Adobe, we believe that this issue may be caused by Photoshop, not by Nik Collection by DxO. They have said that this issue should hopefully be fixed in an upcoming release, versions 22.2, but they do not have a date for release at this time.In the meantime, there are some workarounds you can try to temporarily solve the issue:

  1. Turn off GPU
  2. and / or Deactivate the ruler (press cmd + R on Mac and on Windows ctrl + R)
  3. and / or Change workspace
  4. and or use temporarily previous version of Photoshop : Adobe Photoshop 2020 (21.2.4) as well: you can start a workflow on PS 2021 without using Nik, and continue with saved .psd file on previous version of PS 2020 using Nik, and eventually get back to PS 2021.

If none of these workarounds work for you, we do ask for your patience and wait to test the upcoming release by Adobe of version 22.2 coming soon."

None of the actions (2-3) worked. Option 1 Turn off GPU?! My problem is GPU acceleration lost, turn off GPU of course solve the problem! Thus, I am using v21.2.4 now and would wait v22.2.x to test again. I really wish that DXO support is telling the truth.