Going out of compare mode crashes PL2.2.1

Consistently happening on my system. The latest version of PL, the latest version of MacOS. Press C to go in compare mode, both pressing C again or clicking the buttons crashes PL.

I can confirm this.
And it seems some other irritating behaviors have been introduced.
Such as moving between photos in the filmstrip causes each photo to go out of focus before the preview loads.

1 Like

Confirmed latest HS with latest PL. But until now I even didn’t know about this shortcut, respectively this function. Alway use compare to whole photo if. So I don’t care that much, but understand this is a silly annoying bug.

I had not seen this shortcut either. But it might be useful once they fix it.

Unfortuantely its not only the key command but also the function itself when you click on the button, either to start or to end this mode :frowning:
In other word it is no use for, because it crashes always PL when you switch back.
Should be fixed as soon as possible.

I’ve got a full crash log if DxO needs it, but here are the highlights:

Process:               DXOPhotoLab2 [47871]
Path:                  /Applications/DXOPhotoLab2.app/Contents/MacOS/DXOPhotoLab2
Identifier:            com.dxo.PhotoLab2
Version:               2.2.1 (
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           DXOPhotoLab2 [47871]
User ID:               501

Date/Time:             2019-03-30 15:41:01.702 -0500
OS Version:            Mac OS X 10.14.4 (18E226)
Report Version:        12
Anonymous UUID:        750EA7DB-9ED8-617B-359A-F166A40241DF

Sleep/Wake UUID:       EE2BDEEE-E1F3-4A5F-BAFA-7E3C923DF765

Time Awake Since Boot: 24000 seconds
Time Since Wake:       13000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes:       0x0000000000000001, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
Crashing on exception: Cannot remove an observer <MZVImageLayer 0x60001df0bb80> for the key path "maskPath" from <DOPSplitCompareTool 0x600003066310> because it is not registered as an observer.

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff51060cf9 __exceptionPreprocess + 256
1   libobjc.A.dylib                     0x00007fff7bbf0a17 objc_exception_throw + 48
2   CoreFoundation                      0x00007fff51060b2b +[NSException raise:format:] + 201
3   Foundation                          0x00007fff53258ae7 -[NSObject(NSKeyValueObserverRegistration) _removeObserver:forProperty:] + 476
4   Foundation                          0x00007fff532588ad -[NSObject(NSKeyValueObserverRegistration) removeObserver:forKeyPath:] + 84
5   MZVImageViewer                      0x000000010ea7e8d1 CGColorCreateFromNSColor + 35418
6   MZVImageViewer                      0x000000010ea7d75e CGColorCreateFromNSColor + 30951
7   QuartzCore                          0x00007fff5b9e37c8 _ZN2CA11Transaction6commitEv + 1162
8   AppKit                              0x00007fff4e7320a1 __65+[CATransaction(NSCATransaction) NS_setFlushesWithDisplayRefresh]_block_invoke + 274
9   CoreFoundation                      0x00007fff51007e88 __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ + 23
10  CoreFoundation                      0x00007fff51007dbd __CFRunLoopDoObservers + 451
11  CoreFoundation                      0x00007fff50faa4d0 __CFRunLoopRun + 1136
12  CoreFoundation                      0x00007fff50fa9e0e CFRunLoopRunSpecific + 455
13  HIToolbox                           0x00007fff502969db RunCurrentEventLoopInMode + 292
14  HIToolbox                           0x00007fff5029661d ReceiveNextEventCommon + 355
15  HIToolbox                           0x00007fff502964a6 _BlockUntilNextEventMatchingListInModeWithFilter + 64
16  AppKit                              0x00007fff4e630ffb _DPSNextEvent + 965
17  AppKit                              0x00007fff4e62fd93 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1361
18  DXOPhotoLab2                        0x000000010e463028 uncaughtExceptionHandler + 33382
19  AppKit                              0x00007fff4e629eb0 -[NSApplication run] + 699
20  AppKit                              0x00007fff4e6193f0 NSApplicationMain + 777
21  libdyld.dylib                       0x00007fff7d41e3d5 start + 1

So its not related to the OS, because the same bug in High Sierra and Mojave.

1 Like

And in Sierra!

I do confirm this same issue with Mojave 10.14.3 and DPL 2.2.1 build 30.

This is nothing to do with the OS; it’s a programmer error.

Essentially, this boils down to the fact that the code holds on to a “thing” that is watching for changes in another “thing”. According to the error log, at some point, either the “thing” that is being watched or the “thing” that is watching has been removed from the system, so when the code tries to talk to it, it can’t find it, this annoys the system and it gives up in a huff and crashes the app.

This is not something that should happen but, if they are trying to rush things out to fix a bug, such pressures tend to influence how well programmers do their job. I should know, I’m a consultant software engineer with just under 30 years of experience, including leading major development projects.

1 Like

Hi @BobNL

The bug is currently addressed on our side, it will fixed on the next release.



Great, because I can only confirm it as well. Mojave 10.4.4 as of this afternoon. Crash report available upon request.

Solved with the latest update. Thanks

1 Like

Indeed: no more crashes. Good job!

Confirmed, thanks for this.

I was getting the same problem. The latest update solves the crashes but when I try to look at No corrections/Correction Preview, No corrections shows a blank. This is the case on both my desktop and my laptop machines (iMac and MacBook Pro) so it seems not to be an issue with a single machine. Help!

are you talking about this “split screen” compare? If yes, it works fine on my Mac.

I was talking about both split-screen and compare. Thank you for responding, Sigi, because your observation led me to take another look and change the split screen options from No corrections (without geometry) to No corrections (with geometry) and now everything seems to be working as it should. Problem solved!

1 Like