Getting write protected error when using pureraw 2.0 within lightroom when files are on network drive

I am using pureraw 2.01 on a Win 10 machine. My raw files are on a network share. I can access the photos just file on the network (read and write). However, when I try run pureraw on the raw file using lightroom with the destination folder set to original image folder, I get a can’t process, destination folder is write protected.

Is there a different account I need to create on my server for the pureraw program?

thanks!

Just noticed that I get the same error when I use the standalone version of pureraw2 as well. Wirte-protect error

This sounds like a permissios issue. Have you checked you virus protection isn’t blocking these apps?

On Mac: Tested PureRaw on images stored in iCloud and the storage stick attached to my network base station. Both tests were successful and images were stored on the network drives.

Under macOS, output images belong to the user account with which I launch PureRaw, even though PureRaw belongs to a different account. I’d check permissions in your Win environment:

  • What are permission settings of successfully exported images?
  • Does PureRaw change settings? If yes, what does it do?
  • Have you tried PureRaw with images that reside in a public folder?

I’m getting the same error when PR2 attempts to create the output files on my NAS … .write protect error. Using a work-around with the files going to an internal drive (Windows 10). I have an open ticket for the problem with DXO. Interesting in that when changing the properties of a file and/or folder, it always reverts back to read-only. I don’t have a problem with any other program writing to the NAS (although if I remember I had to define a user on the NAS for capture one. Internal drive also shows ‘read only’, but PR2 doesn’t have a problem with those.

Nowadays you usually have to tell your protection software about every app that wants to use external devices. Just because one app works, doesn’t mean others will.

Bill, glad to hear that I’m not the only one with this problem. Hopefully, they will have a fix at some point. thanks!

What is happening has nothing to do with PureRAW. It is something that needs setting up in Windows security or your anti-virus software.

Joanna, I’ve disabled anti-virus / anti-malware / firewall on this machine. Do you have any suggestion where I should look?

I have the same “destination folder is write protected” NAS issue with PR2 (in Windows 10) and am using the same workaround. I turned off all virus protection apps as a test and still experienced the same issue. I have tried everything I know of, but still no luck. So yes, it appears to be a permissions issue, but I am at a loss to know what else to try. Hopefully, more specific insight into the fix will be forthcoming.

I have the same problem. Is there any solution reported yet?

i have the same problem (Win10 / NAS)

Yes, same problem here on Windows. It does not work on a network drive which is very frustrating. I think I am going to have to wait for this to be resolved before purchasing as I’m currently using a trial.

Same problem on Win11 and NAS. Software seems to be buggy and basic functionality not tested. DxO Pure Raw seems not to be designed profesional usage.

Have you checked that PureRAW has the necessary permissions in Windows to access the NAS?

Since when do I have to authorize a program to save on a NAS drive? In addition, DXO PureRaw2 creates a folder on the NAS.

I reported the issue and got the following response:

Hello Mr S…,

Thank you for your message.
Our development was able to understand the problem that occurs under certain constellations and is already working on a solution.
Please pay attention to the automatic information when starting the software.

Kind regards

B… - DxO Labs Support Team

Michi,

That’s good news. Hope to get this fixed soon.

Tried this today and there is an update available…and it works!

It’s June 2023 and I just started getting this horrible destination is write protected bug. Was there any solution? I have tried installing version 4 but get a message that it cannot be done. There’s no one to call or ask there. This is awful. I’m running a Mac Studio on Sonoma

The way to contact DxO is via this page:
https://support.dxo.com/hc/en-us/requests/new