Free NikCollection will not work with PhotoLab 4 Elite version

Hello everyone I’m new here and if there are any references here to my problem if someone can point me to them it would be appreciated.

I’ve been using DxO for many years now and I’m delighted with it and I have only ever used it with the free version of the NikCollection which I downloaded through Google back in 2012 I think it was. I started off with the original DxO Optics Pro and have upgraded regularly and the NikCollection has worked perfectly with all of them.

I recently upgraded to Pro 4 Elite and immediately after install an update was recommended, DxOPhotoLab_4.0.2_build4437_Setup.exe, I carried this out too. Now when I try to use NikCollection two of the sectors will not work and report a crash, Color Efex Pro 4 and Silver Efex Pro 2. I’ve contacted DxO Customer Support and they cannot help at all as they do not support the free version which is fair enough.

Has anyone else encountered this problem and can anyone suggest a solution please?

My operating system is Windows 10 64bit, though the DxO error log reporting the crashes show my system as Windows 8

Kind regards to everyone.


Hi Oliver

Where are your NIK files located ?
I too previously used the old free NIK Collection which resides in Program Files\Google.

On installing PL4 I also installed the current free NIK collection from DXO here. Which installs in Program Files \DXO. That all worked for me, hope it will for you.


1 Like

Hello Bob,
Many thanks for your response its much appreciated.
Since posting my request as you can imagine I spent many many hours trying different remedies, uninstalling, reinstalling, trying different drivers etc. etc. none of which worked. However a couple of days ago DxO notified me that their Nik Collection was available as a Black Friday offer. In nothing less than desperation I bought it and now low and behold it works perfectly.
Odd that isn’t it? I’ll say no more.
Kind regards,