Filmpack filters not working when a DCP profile is in use

Please note I’m still on PL5 (v5.8). I’ve not noticed this behaviour until now but:

  1. using a .CR3 file from my Canon 90D
  2. if I set the ‘color rendering’ to use a DCP profile (or an ICC profile)
  3. then any filter I pick from Filmpack’s ‘Filter’ has no effect on the image
  4. whereas with all other rendering options (generic, camera body, any film) the filters do change the image

Is this a bug or a feature?

FilmPack 5 or 6 ?

Oops, sorry, yes, should have said, FilmPack 5

Just tried in PL5.8.0 and PL6.3.1 with a *.cr3-file (another cam) as well with *.nef-files – and FP6
(to FP5 – I only get via tif-export to application and there you can apply what you want).

In PL5/FP6 it*) doesn’t work, while it does in PL6/FP6.

Suppose you have to ask @DxO support, if this is a bug in PL5.8.0.

the (Colour) Filter doesn’t work, but Grain, Channel mixer, Creative vignetting …

Ah, so it’s a ‘feature’ of PL5 but not of PL6 :smile:

I will submit this finding to DxO but as the ‘problem’ doesn’t occur in PL6 I can’t see them going back and changing PL5.

It’s not a problem to me. I only stumbled across it when experimenting with using Adobe DCP profiles in PL. I wondered if one image I was looking at would benefit from the Warm Filter, except nothing changed when I applied it. I then tried the Mauve Filter in case the impact of the Warm filter was so subtle I was missing it but when still nothing changed…

All you could do then is to go via tif-export to app …

It’s an old limitation. I reported it to DxO years ago and it was finally fixed.


:roll_eyes: In which case I won’t report my finding to DxO.

I suppose this does give us some insight to the length of the backlog in the PL pipeline, you reported it in Sept 2019 and then three years later with the release of PL6 in autumn 2022, it was fixed.

I have just tried this with PL5.8 Mac and don’t have any problem selecting FilmPack presets when using a DCP rendering.

It’s the filters that don’t have any effect with a DCP rendering, not the presets. (Warm, Cool, Mauve, Yellow, Cyan, Bright Orange…) Thanks for trying this on a Mac, Joanna!

Ah OK. Just tried them and although they seem to work fine on PL5.8, they don’t work on PL6.3.0

You mean this bug doesn’t exist in PL5 for Mac but now has appeared in PL6 for Mac?

Which is the opposite of what’s happened in PL for Windows?

Filters have no effect with a DCP rendering in PL 5.8 on both Windows or Mac for me.

DCP support in PL is fairly broken unless every computer you edit on has the dcp file at the same path since the absolute path is written into the dop file. Mac PL seems to deal with this better than Windows PL. On the Mac the rendering (and crop and maybe more) is silently discarded, but you can import the dcp at its Mac path to get back on track. Try to edit with the resulting dop on Windows and the result is “Internal Error (SetFromUserParams Failed)”.

Fairly unusable unless you want spend your time manually editing dop files.