FIlmpack 7 will not apply luminosity mask

Using latest version as standalone, latest MacOS, M2 mac. Software will not apply luminosity mask. It disappears when I click “Apply”. I can’t save it as a preset. I can’t save image with luminosity mask. Have opened a ticket with DXO but so far it is going no where. Also tried a few different file types including RAW, tiff and jpeg. Also tried on an intel mac. Exact same problem.

I can save other adjustments. I can’t save luminosity masks though.

Hi and welcome to the user forum,

while I’m on Windows … I checked in FP7 standalone with a raw- and a tif-file.

After having selected a certain brightness area with the luminosity mask and adjusted e.g. White Balance & Highlights, I then (1) applied it on the pic and (2) saved the new custom preset.

Opened a very different pic ( did not save the changes to the first pic ) and applied the new preset. This presented me a luminosity mask for an area with corresponding brightness values plus my adjustments. Then I could activate the mask, adjust mask and settings to my liking and apply everything like before.

have fun, Wolfgang