Film Pack Mac: Cannot be anymore accessed on my iMac

I have realised that the Film Pack app has disappeared from my hard drive.

I then downloaded from my DX-O account and attempted to reinstall it. The installation failed returning the following message:*** -[NSBundle initWithURL:]: nil URL argument.

Can you help identify what the problem is?

Hello. Can you please attach install log here.

  • Please start the FilmPack installer application again.
  • After installing, please press L (command and L), this will open up the ‘Installer Log’ window
  • In the upper left corner of the ‘Installer Log’ window, please select ‘Show All Logs’.

Here is the log from the failed installation:

Installer Log 16-Sep-2019.txt (18.3 KB)

Can you try launching and then install FilmPack again?

I had tried this out already.

I solved the problem yesterday in a drastic way. I simply clean installed MacOS Mojave, by wiping out my ssd before. Then I used a time machine backup to transfer back all my data and apps. Everything runs smoothly know.

However, it seems that there was a specific kernel extension which was causing the problems on my Mac. It probably interfered with other apps on my machine apart from PhotoLab2 and Filmpack 5. With the clean install I managed to isolate and hopefully eliminate this issue. The kernel extension was Joshua Wise System Software driver.