File error - Image cannot be processed because of unknown error

Recently purchased an upgrade from DXO 2.0 to 3.0. Uploaded a few files, and I get the message in version 3.0 “This image cannot be processed because of unknown error. It may be corrupted or unsupported format.” It is random and doesn’t happen in DXO 2.0 nor do I have problems with the same file in DXO 2.0, Lightroom or Photoshop.

Mac OSX Catalina 10.15.6


Is your PhotoLab 3 up-to-date? The latest version for Mac is 3.3.2. but you mentioned using 3.0.

Also, does the problem occur if you copy your image(s) into a new folder and open PhotoLab there? If the failing image has a .dop sidecar file, does the problem go away if you remove that file (temporarily)?

I have PhotoLab version 3.3.2

I copied the images to a new folder and opened PhotoLab 3.3.2 there and the same issue. Deleted the .dop sidecar files - same issues.

No problem with PL 2.4.0.

Hello @rdwhite629,

Will you, please, provide us with some files via for the test and analysis?

Thank you,


I sent two photos xxxx50 worked fine and xxxx51 didn’t work.

Hello Robert,

I have no problem with your 2 images in PhotoLab 3.3 on Windows.
Maybe there is a problem with the sidecar (file .dop) or database because of a seeting from PL2, can you put your images in a new folder and retest ?


I have tried to copying to a new folder and it works sometimes - sometimes it doesn’t. I have deleted all the sidecars and it doesn’t make a difference. However, I did one thing that worked - pain to do but worked. I opened up PL 2 and selected all the photos. Made a slight exposure adjustment and then adjusted the exposure back to 0 thus creating a sidecar for all the photos. I closed PL 2 and opened PL 3 and no longer got the message that the image could not be processed. I can do this work around for now but this issue needs to be addressed. Thanks,

OK, I’ve informed our Mac team about your issue. They should have a look at it.


I’m getting the same with some Pentax pef files which I’m sure used to open. However, I 'm getting the same error in both PL2 & 3 (both are up to date). but can open the same files in every other app I’ve tried so far. Aperture, Photo Raw, Affinity Photo, Preview, etc
MacOS 10.15.6
I also get the same error with raw files from my Google Pixel, but believe that is a different issue.

Thanks for sharing the knowledge. Appreciated!

I don’t know if this is why they aren’t opening, but when it tries most of the exif data is blank. It does exist though as other apps display it. So for some reason PL 2&3 aren’t able to read it.
There doesn’t appear to be a pattern though. Some files from the same camera, in the same folders, open, & others don’t. Bit weird.