Feature Request: New Update Available - turn off check box

Already when Photolab 4 was new people seem to have asked for a possibility to disable the “New Update Available”- popup.

The problem seems to be the same with Photolab 7. I and 7.2. I am forced to stay with 7.02 since version 7.1 and 7.2 doesn´t seem to read the XMP-data from the files correctly which I have reported in a bug report earlier. Nor does the automatic XMP-synch work.

… and every time when I start Photolab 7.0.2. I get this pop up. Can we get a check box so we can turn it off please?

So if you can´t fix the problems with the XMP-metadata soon in version 7.1 and 7.2 you might at least give us a chance to turn of this annoying popup!


Maybe you could try this :

  1. Exit DPL and make a backup of C:\Program Files\DxO\DxO PhotoLab 7\DxO.PhotoLab.exe.config

  2. Open this file in a text editor.

  3. Look for this section :

      <setting name="WSCheckForUpdatesUrl" serializeAs="String">
  1. Temporarily remove it (all 3 lines). You can also merely replace the URL with a fake one, so that the connection fails. Save the file and relaunch DPL.

  2. If this doesn’t solve the problem, restore the original file after exiting DPL. If it works, restore this section in the config file once you think a newer version will solve the metadata problem.

You can also try the same trick with another section :

      <setting name="PrefsAutoUpdate" serializeAs="String">

or merely replace True with False.

It no longer corresponds to any option in the preferences and seems to be a left over from the Mac version or from older DPL versions.

Good luck.

I can’t try these tricks on my system because I’m already up-to-date. Sorry.

1 Like

Thank you Patrick!

Happy New Year to you!

PL7… go in your setting, first tab and click it off, that’s not new, no need to feature request as it’s already an option.

and there’s also this option from Nik as shown but also with PL

Thanks Mike for your effort but it seems like it is only the Mac-version that has this feature.
… and another thing: I would probably not have found it in “References” if it had been there since it would not have been the place I would have been looking for it at :-). I think a possibility to turn it of should be located as close as possible to the situation this function is causing - which means on the pop up itself.

well… time for DxO to fix this small inconvenient issue. I’m sure it’s not a hard script to write and can be done in time for the next update to PL.

1 Like

I deleted the search path and that worked.
Had to change a few user rights too.

What happened though is also that the “Check for Updates” menu in the Help-menu ceased to work too but that´s fine for now.

The task was to silence the popup and that definitely worked. So thanks again! This error message is just a cosmetic problem for me :slight_smile:

Still I think this problem needs to be fixed as I have sugggested.

I should have mentioned that the change should be made under an administrator account. Sorry.

1 Like

There are tons of “script not hard to write” that should be but are not written …
The basics aren’t respected ; example : do you know any other software where there are things which can be named, but not be renamed ? … yes, unbeleivable, isn’t it ?
So …