Fails installing update to PL 5.1.1 from 5.1.0 on Windows 10

Cannot update to PL5.1.1 from PL5.1.0 on Windows 10 Home, 64bit, Version 10.0.19043 Build 19043
Install stops and states the WixInstall_photolab5.msi in my user/AppData/Local/Temp folder is not a valid installation package.

I’ve submitted a support request, but wonder if anyone has worked through this already who can expedite an answer here?


Never had an issue installing updates in the past few years since owning PL5.
My AV reports no issues detected, and nothing listed in AV history logs.
I’ve Run as Administrator.
I’ve AV scanned the WixInstall_photolab5.msi file with no issues reported.
I’ve opened the WixInstall_photolab5.msi file into my text editor so I know it can be opened.
I’ve rebooted and immediately run the install.
I’ve downloaded direct from my DxO purchase account, and also did the download within PL5.
The install file is always the same number of bytes.

Anyone know anything about this?

A somewhat different situation, but I had a problem after updating to Windows 11 and then updating to 5.1.1. In my case, install went OK but I had to delete the PL database, which had apparently become corrupted and prevented images from being loaded into the program. But if your issue is with the installer, it may not be related.

Greetings @BBT
Sounds like you probably have a good copy of the installer since you’ve downloaded more than once. Appears to be related to something in your OS environment.

What feature build of windows are you running?
What AV are your using?

Next steps:
Start menu type %temp% and press enter

Inside you should find a DxO PL5 Installation Log.log
DxO Installation Bootstrapper Log.log

Can you post those for us to review?

Now… Delete all the files from your temp folder (you won’t hurt any thing)

Now open an elevated command prompt or powershell
Run System File Checker

sfc /scannow press enter

Hopefully no integrity violations found, or if so successfully repaired

Leave PL closed.

Try running the upgrade again >5.1.1

Let us know the results.

Thanks Rick, you gave me some things to work on. But still fails with same error message.

I realize it’s unlikely divulging my AV will allow someone to exploit a possible vulnerability that they know about (after they’d need to first figure out my IP address), but regardless of the AV, when I look at it’s history log, there has been nothing found – so I presume the AV didn’t intentionally prevent access to the MSI install file during install. I’m reluctant to turn off my AV because companies sometimes release code that’s infected. And because my install code isn’t working, that’s not a great time to trust that it’s not infected (altho the install file was likely scanned by my AV during placement, I also manually scanned the WiXInstall_photolab5.msi file and it was fine – so I suppose that should give me confidence that it didn’t intentionally prevent access during the install, but also that I can probably turn off the AV during install). I’m going to wait to hear back from DxO to see what they say before turning off my extremely commonly used AV. I also manually scanned with free version Malwarebytes (which isn’t running real-time and has no issues reported in it’s history log).

Instead of deleting all temp files in my user/AppData/Local/Temp folder, I used CCleaner which left very recently created/modified files. But now there’s only 100MB used in the Temp folder versus nearly 1G before cleaning.

PL 5.1.1 still does not install after also running the following:

  1. Dism.exe /online /Cleanup-Image /checkhealth → no issues found
  2. Dism.exe /online /Cleanup-Image /scanhealth → no issues found
  3. sfc /scannow → the following was copied from the prompt window

"C:\WINDOWS\system32>sfc /scannow

Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations."

And the photolab5_installer_bootstrap_log.log report:

Bootstrap - DxO PhotoLab 5 - 2021-12-17 18:01:32
IsPlatformSupported => Major: 10
IsPlatformSupported => Minor: 0
IsPlatformSupported => Build: 19043
Installed .NET version: 528372
Initializing PhotoLab installation.
InstallProduct => Run command: msiexec /i "C:\Users\~\AppData\Local\Temp\WiXInstaller_photolab5.msi" /log "C:\Users\~\AppData\Local\Temp\photolab5_install_log.log"

And here’s the last bunch of lines from the “photolab5_install_log.log” report (starting after any lines which included specific names and IDs related to my specific PC).

I searched the whole log file for “fail” and found none above the only one that’s at the end of the log message (below).
I searched the whole log file for “found” (to find any “not found”, and each instance of “found” appeared successful).

Property(C): SystemLanguageID = 1033
Property(C): ScreenX = 1920
Property(C): ScreenY = 1080
Property(C): CaptionHeight = 29
Property(C): BorderTop = 1
Property(C): BorderSide = 1
Property(C): MsiTabletPC = 1
Property(C): TextHeight = 20
Property(C): TextInternalLeading = 4
Property(C): ColorBits = 32
Property(C): TTCSupport = 1
Property(C): Time = 18:02:36
Property(C): Date = 12/17/2021
Property(C): MsiNetAssemblySupport = 4.8.4084.0
Property(C): MsiWin32AssemblySupport = 6.3.19041.546
Property(C): RedirectedDllSupport = 2
Property(C): AdminUser = 1
Property(C): Privileged = 1
Property(C): USERNAME = Windows User
Property(C): DATABASE = C:\Users~\AppData\Local\Temp\WiXInstaller_photolab5.msi
Property(C): OriginalDatabase = C:\Users~\AppData\Local\Temp\WiXInstaller_photolab5.msi
Property(C): SOURCEDIR = C:\Users~\AppData\Local\Temp
Property(C): VersionHandler = 5.00
Property(C): UILevel = 5
Property(C): WIX_DIR_ADMINTOOLS = C:\Users~\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools
Property(C): WIX_DIR_ALTSTARTUP = C:\Users~\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
Property(C): WIX_DIR_CDBURN_AREA = C:\Users~\AppData\Local\Microsoft\Windows\Burn\Burn
Property(C): WIX_DIR_COMMON_ADMINTOOLS = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
Property(C): WIX_DIR_COMMON_ALTSTARTUP = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
Property(C): WIX_DIR_COMMON_DOCUMENTS = C:\Users\Public\Documents
Property(C): WIX_DIR_COMMON_FAVORITES = C:\Users~\Favorites
Property(C): WIX_DIR_COMMON_MUSIC = C:\Users\Public\Music
Property(C): WIX_DIR_COMMON_PICTURES = C:\Users\Public\Pictures
Property(C): WIX_DIR_COMMON_VIDEO = C:\Users\Public\Videos
Property(C): WIX_DIR_COOKIES = C:\Users~\AppData\Local\Microsoft\Windows\INetCookies
Property(C): WIX_DIR_DESKTOP = C:\Users~\Desktop
Property(C): WIX_DIR_HISTORY = C:\Users~\AppData\Local\Microsoft\Windows\History
Property(C): WIX_DIR_INTERNET_CACHE = C:\Users~\AppData\Local\Microsoft\Windows\INetCache
Property(C): WIX_DIR_MYMUSIC = C:\Users~\Music
Property(C): WIX_DIR_MYPICTURES = C:\Users~\Pictures
Property(C): WIX_DIR_MYVIDEO = C:\Users~\Videos
Property(C): WIX_DIR_NETHOOD = C:\Users~\AppData\Roaming\Microsoft\Windows\Network Shortcuts
Property(C): WIX_DIR_PERSONAL = C:\Users~\Documents
Property(C): WIX_DIR_PRINTHOOD = C:\Users~\AppData\Roaming\Microsoft\Windows\Printer Shortcuts
Property(C): WIX_DIR_PROFILE = C:\Users~
Property(C): WIX_DIR_RECENT = C:\Users~\AppData\Roaming\Microsoft\Windows\Recent
Property(C): WIX_DIR_RESOURCES = C:\WINDOWS\resources
Property(C): ROOTDRIVE = C:
Property(C): CostingComplete = 1
Property(C): OutOfDiskSpace = 0
Property(C): OutOfNoRbDiskSpace = 0
Property(C): PrimaryVolumeSpaceAvailable = 0
Property(C): PrimaryVolumeSpaceRequired = 0
Property(C): PrimaryVolumeSpaceRemaining = 0
Property(C): INSTALLLEVEL = 1
=== Logging stopped: 12/17/2021 18:02:36 ===
MSI (c) (88:EC) [18:02:36:630]: Product: DxO PhotoLab 5 – Installation failed.

MSI (c) (88:EC) [18:02:36:631]: Windows Installer installed the product. Product Name: DxO PhotoLab 5. Product Version: 5.1.1. Product Language: 1033. Manufacturer: DxO. Installation success or error status: 1602.

This is a long shot, but it’s possible your AV doesn’t (yet) recognize the most recent version of PL. I used to run into that frequently when installing brand-new programs that AV companies hadn’t yet been programmed to recognize. For what it’s worth, I haven’t run into this lately when running Windows Defender.

Temporarily disabling antivirus can be helpful. A few more things to check:

A. Does your user account name have any strange characters in it? Or is it blank?

B. Steps 7, 8, and 9 here: This installation package could not be opened message in Windows 11/10 (

C. Did you download the installer to a local computer folder, network storage, a shared resource, the cloud…?

There is no way you telling someone what AV you are running would put you, your computer or data at any risk. Like telling someone you have chrome installed. They can’t do anything with this information.

I’m running Windows Security.

aVAST :bomb: has been reported by some as being problematic

@Egregius has some good suggestions.

I know your SFC already came back clean.

Won’t hurt for you to rereg the Windows installer Service, check its running normally etc.

May not hurt to check your system event log either

What’s still possible:

Your AV
Running file from remote location
Other installed application in your environment
-Are your video drivers up to date (or relatively current)?

Well, I tried something different and the install seems to have worked regardless of having stopped to inform me that the install package was invalid for DxO.

This time, instead of me closing the fault dialog and then me cancelling the install process so it wouldn’t continue despite a major error, this time I let it continue until it was satisfied it was done. Previously, I had been afraid to lose my good install to a defective update install. I did notice earlier that the install wanted to continue doing something after I closed the error dialog, but I had always stopped it to prevent potential corruption.

Now the log file doesn’t show the error and it’s a much longer list of activity.
And at the end of the install log file: “=== Logging stopped: 12/17/2021 21:43:16 ===
MSI (c) (74:5C) [21:43:16:744]: Product: DxO PhotoLab 5 – Installation completed successfully.”

And I when I run PL5 I see it’s revision 5.1.1

PL5.1.1 seems to be working.

Go figure???
Perhaps some sort of short time-out to produce the “bad install file” dialog, but it kept trying and eventually discovered the file was present? That doesn’t sound quite right because I had retried using the “bad install file” dialog to look for it again many seconds after it popped up and still got the “bad install file” dialog popping back up on each retry.

One of the causes of the 1602 error does indicate installation cancelled by user, but until you said you cancelled it, I didn’t think it was initated by you. Sometimes a little patience goes a long way. I’d do some editing and exports. If you don’t see any problems, you might be ok. Glad you were able to get it installed

Thanks, Rick. So, it wasn’t really lack of patience as much as distrust of a process which threw a ginormous error. I mean “invalid installation package” sounds pretty bad. Who would really want to let that continue despite repeated same message each time you allow that dialog to retry again and again before manually closing that dialog so that it falls back into the progress bar moving again with the Cancel button available.

Mind saying where you found what different error codes mean?

One resource here, but there are others:

Windows Installer Error Messages (for Developers) - Win32 apps | Microsoft Docs

Hey that’s great Rick. I was thinking the error codes were DxO internal codes. But sure, they’d pass Windows Installer codes into their log file (or perhaps even the whole log file is generated by Windows Installer Service and not by DxO at all). Thanks again.

I’ll post an update here about what DxO says about this install fault I’ve been getting. Hoping they respond even though I wrote to give them my progress (seemingly a successful and proper install despite still getting a fault message long before the install has completed).

Have you tried to do a Disk cleanup to erase the temp files?

And CCleaner cleaned other temp locations. The install still throws an error, but apparently finishes up alright (so it seems, so far).

It worked for me.
Downloaded the update and simply ran it without issue.

It does work, at least for me!

Good morning!

@BBT could you, please, give me the support ticket ID to link?

Thank you
Svetlana G.

Here it is @sgospodarenko : Ticket ID#310121 Request received : fails to update to latest revision

Thank you!

Svetlana G.