External HD not showing in PL7.2.0?

Hello everyone. Maybe a stupid question, but at the moment I cannot find anything inside my external HD when in PL7. The external HD is showing inside “Devices” in PL (as does “Macintosh HD”), but it’ s impossible to open it’ s contents (message I get: “This folder does not contain any image” ).
I’ m sure that not too long ago I could work of this external directly in PL. I still can see all my images (and other backups) placed in that external hard disk when opening Finder.

I probably do doing something wrong now?
All tips/advice very welcome!

Thank you very much

Just to clarify ; Under “Devices” in PL7.2.0 I can see my external HD. There’ s no way to see (sub)folders inside it…no way to open this “Device” , as I can with Macintosh HD. In the past I could open External HD…go to a photos folder inside it…open it and choose specific folder to open images.

Inside PhotoLibrary I can see:
“Recent Searches”
“Devices” (here there are 2; external HD + Macintosh HD).

Am I missing something?

I really hope someone can give me advice on how to solve this.

Try to set the external drive to “ignore access rights” at the bottom of the Information you get with cmd-I. Does that help?

Here’s the place to check the box:

Other than that, things work as expected…

…with access rights granted in system preferences/settings.

Full disk access is not necessary. If you delete the entry (or the one in “Files and Folders”), macOS will ask you to set rights when necessary. Answered once, it will not ask again, so think carefully what your needs for security or convenience are.

Note that a time machine backup drive is blocked by respective access rights.

thnxs Platypus. Mac is busy now with giving access rights to “wheel” / “system” / “everyone” …I hope that 's what you mean??

There is no “ignore access rights” as I can see there.

Takes (too) long? forced quit process…don’ t know for sure if you mean this.

Wheel / System/ Everyone…reading and writing as usual here…allowed. Is that what you mean?

Or should I make this Volume (external HD) “Shared” …tick the small box below the general information I get with cmd-I

And then…strange that I can access and open images directly from my external HD when I work in Affinity Photo / Pixelmator Pro / ApolloOne/…
Maybe this points towards something wrong inside PL??
There aren’t any folders inside my “Lacie d2 Professional 10Tb” (my external HD)…so nothing to open!

Hi there.

Have you given PhotoLab access rights for o the drive in the security and integrity settings in macOS?


Indeed. This has been mentioned many times before.

This must be the definition of stupidity!!
I simply didn’ t think of those access rights! First thing I should have done…instead of panicking!
Feels like shooting a major event without any sd card…pfff…very embarrassing!

Thank you platypus/ Required and Joanna!
All is well now.

1 Like

Not at all. just not being familiar with macOS.

Take up LF film photography - there are so many more chances to “demonstrate stupidity”.

  • forgetting to load film into your dark slides before leaving the house
  • inserting the film in the dark slide with the emulsion to the rear
  • not having the dark slide set to un-exposed or losing track of which sides have been exposed.
  • removing the dark slide before closing the shutter, resulting in a totally black negative
  • not removing the dark slide before pressing the shutter, resulting in a totally clear negative
  • forgetting to stop down the aperture after focusing
  • etc

:rofl: :stuck_out_tongue_winking_eye: :crazy_face: :flushed: :face_holding_back_tears:

Well, after my third iMac, I like to think I’m (a bit) familiar with macOS :slight_smile:
That’ s exactly why I consider this pretty stupid…I simply didn’t think of this.
And yes…there are more ways to demonstrate stupidity. I’ll not even try to mention the mistakes I made in photography :wink:

But then…it all started again!
No access to external HD…what?? Again??
I HAVE given PhotoLab access rights for o the drive in the security and integrity settings in macOS…and it worked perfectly fine for all day.
Then…shutting PL…and wanting to start again…same problem…I cannot open external HD!

Grrrrr…i’m puzzled…again!
It looks like I need step by step guidance here.

and then…I just disconnected my external HD. Waited for a few minutes. Connected again. Opened PL7 (version 7.2.0), and then…voilà…it’s there again and I can open it again. Seems good now.
That’ s strange, because before I could get into external from other photo programs…just not from PL.
So, I’m waiting for the next time this happens again…probably will be continued…

yes…continuing story…after closing PL…opening again after half an hour…no access to external again!

Any ideas?..maybe remove PL7.2.0…and fresh install?

Which macOS are you on?

Ventura 13.5.2

should work, right? Or should I update to Sonoma 14.2.1?

And now…works again.
Filed a request . I hope it’ll stay like this. Evening now…will look back into this tomorrow.
Thnxs for all help/advice.

Is the format of your external Drive on NTFS or on ExFat. As NTFS is for Windows and Mac cannot write on it, only read. The best way to use as well on Win and on Mac is to have external drives in ExFat. Take a look at it as it may be the solution.

thank you dAprilli. External drive is formatted as it should be.
All is (still) well now. I probably have changed a setting somewhere I cannot remember. I think it will stay ok; opened and closed many times since the day before yesterday and I can work from external HD like it used to be. So…problem solved.

1 Like

I know! Frustratin’ Ain’t it? I have an external drive that randomly(seemingly) disappears from some program I’m using. Fortunately, I just go to This PC and there it is.