Exporting to Luminar Neo Issue

When I try to export from DXO to Luminar Neo, the JPG copy of the RAW file is created, Luminar Neo opens, I edit the photo, but when I close Luminar the JPG file is not updated with my changes. Has anyone else encountered this problem and solved it? Thanks for any guidance.

Does Luminar Neo’s editing actually change the original JPEG file, or is it non-destructive like PhotoLab?

Good question. It’s non-destructive, but even when I try and export it doesn’t work. I think it’s a Luminar issue.

It’s not really a “Luminar issue”.

Think about it - editing a RAW file in PhotoLab doesn’t change the RAW file. In order to see the changes you have made, you need to export to either JPEG, TIFF or DNG files. So, now you are dealing with a copy which knows nothing about how it was edited.

Then you take that newly created JPEG file and open it in Luminar Neo. If you then apply further editing to the newly created JPEG, those changes are only saved to the catalog and the only way to see the changes is to export the file once again.

So, now you have…

  1. the original RAW
  2. the JPEG exported from PhotoLab
  3. another JPEG exported from Luminar Neo

Although you say you are exporting to Luminar Neo, what you are actually doing is simply exporting a JPEG to disk and then asking Luminar Neo to open it. Neither application knows anything about the other. You might as well export to disk and then edit the exported file - nothing is ever going to change from PhotoLab’s point of view unless you export the file edited in Luminar Neo and then open that copy in PhotoLab.

1 Like

Not exactly. I exported the edited JPG from Luminar Neo back to the same directory that DXO created the copy, when I got the prompt that the file already existed I chose for Luminar to replace it. It worked once but not again. For some reason Luminar is not outputting and overwriting the File with the edited version even though I chose to replace it.

Did you close PL, when you edited your JPEG in the other program … ?

Funny you said that. I’m thinking the file is being held open and the replace fails even though there is no indication of it. I’m also thinking that I can’t export to the same file that is open and being edited in Luminar. I have to create a new one. Luminar should prevent you from doing that if true. Thanks.