Export to Lightroom without stacking?

Is there a way to prevent the stacking of images that are exported back to Lightroom from DxO PhotoLab 5? I don’t want to have to manually remove the stacking every time I bring back images into Lightroom. I do not use stacks nor do I want to start using them.

While I’m on Windows, PL is not doing any stacking, so check in LR …

→ Preferences

→ stack with original
Screen Shot 12-22-21 at 04.11 PM

(screenshots taken from LR5.7)

@Wolfgang, please add some context to your screenshot. We see the needle, but we still don’t know, where it is in the haystack…

1 Like

Well, I am on Lightroom 11.1 and on MacOS, so I don’t think this helps me at all. Thanks anyway.

1 Like

Found the switch in Lightroom’s settings. It’s switched off on my Mac, exports still come up stacked…

Looks like a BUG - question remains: Where? Lr or PL?

Answer: Bug must be in PL, Photoshop sends the resulting image without stacking it!

I agree, it seems like a bug (or unwanted feature) in PhotoLab. Probably hard-coded in the Import plug-in.

Wolfgang, where in LR is the menu you show in the picture?

Well, I am on MacOS, so maybe it is a Mac thing. I could not find any place in LR that would address the issue. Thanks anyway.

in my old LR 5.7 Windows version → Preferences → Stack with Original
Export to Lightroom without stacking? - #2 by Wolfgang

That’s the only spot I know of “stacking”. But as @platypus mentioned, it doesn’t seem to help …

On a Mac, the setting is here:
Bildschirmfoto 2021-12-23 um

Other than that, stacking seems to be hardwired…I found no switch (without digging too far)

Thanks, platypus. I have that option un-checked but it does not help.

I wonder if this can be fixed by replacing the photoToStackWith action with nil in the line just before the end of the function?

Try it, if you know what you’re doing…and let us know if it worked.

It works! I just tested it. Edited the .lua file using a plain text editor, and saved it. I did what I mentioned above, forcing the photoToStackWith to nil in both cases of the if statement.

I sent a raw file from LR to DPL, made some edits, exported to LR from DPL. In LR, the file got imported (after the usual delay) and NO STACKING!

Thank you very much, I really appreciate all your help. As I suspected, this was hard-coded, but I didn’t know to look in the .lua file.

1 Like

Please post the modified file (posting should work as .zip)

Here it is…PluginInit.lua.zip (2.8 KB)