Export Options

I am sorry to ask a dumb question but I am stumped. I upgraded to the latest photo lab version and when I go to export a file I’ve lost all the options to export (format, action, quality, destination, resize, watermark, ICC profile, etc.). I’m sure it’s a simple fix. Can anyone help?

Hi Paul

Do you own PhotoLab 6?
Is it still installed?
The settings are in a system file and will be taken over.

The easiest way is to uninstall and reinstall PhotoLab 7.4


1 Like

Is it Mac or Windows?

I would really prefer not to reload. I bought a new window laptop (Dell) and loaded the new upgrade to the laptop. I had a heck of a time because Nik would not load with PL and it resulted in rewriting a script that fixed it.

It’s a Window laptop. All I see for export options are action, quality and destination. I don’t see the more detailed options from PL 6.

For PL7.4/Win11, maybe similar in PL6:
Found export settings in my home directory at
AppData\Local\DxO.PhotoLab.exe_StrongName_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx\\user.config , where ‘xxx…’ looks like some hash, maybe unique to installation/license.
Maybe there is some file access problem with user.config for the previous version?
On Win11 update PL7.3 → PL7.4 preserved my settings.
Previous user.config files are still there in the,, subdirectories
of AppData\Local\DxO.PhotoLab.exe_StrongName_xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx .
In FileExplorer Options->View you have to enable ‘Hidden files and folders->Show hidden files, folders, or drives’ to get there. However, the problem sounds more serious to me. You should be able to see at least the export defaults, if there is some access problem or PL should not start at all. Just guessing…
BTW, I wouldn’t touch any user.config files, but if you have to risk, be prepared to reinstall.

Side remark: The ‘StrongName’ thing is related to .NET strong assemblies, whatever that is.
It’s the same in my case as mentioned in @Pieloe’s link, so it’s not installation or license specific. It’s specific to PL7 application as a whole.

Thanks for the response. I am not tech savvy so you are right, I am not seeing the default export settings. I will try the options - view to see if that is the issue. Should I try reloading PL6 and then load PL 7 again?

I tried as you suggested and enabled the hidden folders and files and that did not work. Any other thoughts?

I own PL6 but it is installed on my desktop. I downloaded PL7 on a brand new laptop.


In that case, copy these files from your desktop.

1 Like

My intention was to make it visible for you – PL should work in the same way with or without this setting. But if you don’t have tech background, better switch this option OFF. Otherwise you may accidentally run into very serious problems on the OS level. Follow @Pieloe advices, who is more experienced with PL than me.

1 Like

I found the update messed up my exports as well. I had one setup for Facebook and I had to delete it and redo it. Even though it was showing the right settings it exported at full size?

@Doucer1 could it be related to Upgrade to PL5.1.0 Build 4690 from previous PL5.1.0 build - Export to disk options lost, reverted to defaults?

If I remember correctly it was related to the config file not being copied successfully or something like that.

The user.config is to be found here in my case

If DxPL cannot find an appropriate user.config file it will look back for a previous copy to use as its starting user.config or something like that.

So the “recovery” strategy was something like.

  1. Close DxPL
  2. Remove the “current” config file or move it to another location.
  3. Restart DxPL which should go looking for a suitable user.config file as an appropriate starting point.

Check the topic to see if the circumstances fit your scenario.

PS:- If you are working with a new system then you will need to supply the user.config from another machine that has been configured with the export options that you require!

The original problem was caused by a bug in an updated release but in the case of commissioning a new laptop there is no “old” user.config to use as a starting point so you will need to supply one!