Experience with Non-Adobe Editors

I have been successful installing the Nik Collection by DxO to run with two of three non-Adobe editors on my iMac (macOS High Sierra 10.13.5).

PhotoLine 20.54 – All of the plugins will run in layers in this German-published photo editor. The brush function available via Photoshop is not functional, but by using layers you can come out of the Nik-DxO plugin and use a brush in PhotoLine. I have not tested PhotoLine actions with a Nik-DxO plugin

Luminar 2018 – All of the plugins appear to behave properly in Luminar 2018. A separate layer is created when one of the plugins is called from this editor. Same situation here, no brush within the plugin, but your can use a Luminar brush after coming out of the filter. It appears you have to go to each one of the plugins and use it before Luminar remembers the location. After that, each plugin is shown on the dropdown menu.

Affinity Photo – The programmers of this increasingly popular editor need to do some tweaking of their app, because it won’t run the new Nik-DxO plugins. Since both PhotoLine and Luminar will run the filters, I believe the problem is with their code, not DxO’s.

Finally, if you have more than one non-Adobe editor and intend to use the Nik Collection by DxO with them, it would be better to do a custom install to only one location, and then point each editor to that address in its setup. The installation app for the Nik Collection by DxO makes it very easy to perform the custom installation. The actual plugins are installed there, while the standalone exe file for each of the filters is installed in a folder within applications.

For Affinity Photo that’s not true. I got to run some (but not all) with this explanation: https://carstengrimm.com/blog/affinity-photo-und-nik-collection
It’s in German but you can use Google Translater. For Silver Efex Pro 2, it doesn’t work because the picture is prepared undless and nothing happens. But Viveza and others work fine for me.

More experimentation with the Nik Collection by DxO in Affinity Photo (on an iMac) –

Dfine, Sharpen Output, and Sharpen (RAW Presharpen) appear to work correctly.

Viveza works correctly excerpt the old bug with incorrect rendering of image color in the window was not fixed. (The Loupe shows correct color).

Analog Efex Pro, Color Efex Pro, and Silver Efex Pro hang while opening on “Preparing Image.” HDR Efex Pro hangs while opening on “Preparing HDR Image.”

The old version of HDREfex Pro used to crash on Mrs all the time.
The DxO very hasn’t crashed once

MEB, one of the moderators on the Affinity Photo forum, indicates all the Nik Collection by DxO will run in the Windows version of Affinity Photo, but none will run in the Mac version of AP.

I’m sure the Affinity engineers will eventually eliminate the Mac problems.

Regarding my reply in your other post Old Color Rendering Bug Still Present
I’ve tried with Affinity and Viveza plugin (before I thought it was not working) and I have also color rendering problem.
As the problem is not there with the autonomous Viveza application, perhaps this is also due to “incompatibility” between Affinity and Viveza as we have also problems with hang with others?

1 Like

Has anyone tried to use this NIK collection with the old PaintShopPro? Since it is able to use 8bf plugins, I’m hoping these will also work.