Error Installing 5.0.1_4658 over 5.0.0_4639

Good Morning. It might just be me. I’m currently investigating the below:

Windows 10_21H1 (19403.1348)

501 Setup
DxO.PhotoLab.txt (312.9 KB)

Log file attached. Also tried uninstalling 5.0.0 but this fails as well.

Downloaded the installer twice.

Otherwise healthy system, SFC reports no errors. Just posting this in case anyone else sees this issue. If I find a solution, I’ll post it.



  • same system – no problem on my side
  • try to uninstall from Windows not with DxO’s uninstaller

Agreed. I also recommend launching a PowerShell with administrator privileges and running “sfc /scannow” to see if any Windows components are missing/corrupt - in which case Windows will try to repair itself.

1 Like

As stated in my original post, SFC was clean.

Also tried both methods for uninstall, windows and DxO.

Threw the following at the issue:

Bounced the Windows Installer Service (services.msc)
Performed clean install of nVidia drivers 496.13 > 496.49
Ran DISM.exe /Online /Cleanup-Image /Restorehealth (even though SFC reported clean)

Issue resolved. Can’t say which helped, but 5.0.1 is installed and happy now.




Problems like this make me worry more about the integrity of my photo archives. I find myself using larger and larger HDDs for occasional full or differential backups in addition to other local and cloud backups. :sweat_smile:

Indeed, I moved to using a NAS, with two mirrering disks in the my desk pc. Luckily my son and I backup over night to each others NAS boxes so hopefully there are 6 copies without plugin HDD boxes.