Error: DxO PL2 e won't close at "quit"

additional to my stronger PC I’m also using a Mac Book Pro 2009.
After updating to the actual Version 2.1, I have the problem, that PL on this Mac won’t quit, when I try to. The formerly PL 2.0 worked well.
It seems (after a couple of tries), that this error occurs after exporting a photo, but not after just opening the application or editing without export a photo.
The colored wheel is rotating on and on and PL could only be quit the hard way.
I try to avoid a complete new installation, when there is a chance, because of the adapted user interface and imported presets.
Anyone her with the same experience or a hint?

Maybe the OS you are running. I guess on the MBP 2009 you can run Sierra only. On my MBP 2011 with HS I never had any problems.

Yes, it’s 10.11.6. a newer can’t be installed.
Before upgrading from PL1 to PL2 I first used the demo to be sure, that PL2 will work and the former 2.0.1 worked properly.

I know it makes no sense, but sometimes its a difference to quit an app bei “command+q” or from the menu. Apart from that I would try the common voodoo tricks like starting without extensions (secure mode), which also does a check up while starting.

Same problem here. I upgraded to PL 2 and then accepted the update to 2.1.0 Build 14. The first time, I thought it was just a one-off, but now it has happened twice. Symptoms are Command-Q followed by the Mac spinning beach ball. Force-quit is the only way to recover.

I can’t tell if any work is lost; so far it does not appear to be so.

Hardware: MBP mid-2016 16GB memory and Sierra OS. If you have instructions for what to capture or how to trace what is happening on a quit, let me know and I will put it in place.

Normaly you can check it in the console app. In german its “Konsole”. Hope translation is correct. You can find it in Utilities.

From Console –

Process: DXOPhotoLab2 [1344]
Path: /Applications/
Identifier: com.dxo.PhotoLab2
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: DXOPhotoLab2 [1344]
User ID: 501

Date/Time: 2018-12-07 23:20:09.095 -0500
OS Version: Mac OS X 10.12.6 (16G1618)
Report Version: 12
Anonymous UUID: EF1B2F0F-3ED1-1CB2-76B2-A15F08389CA8

Time Awake Since Boot: 150 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
__TEXT 000000010eace000-000000010eb04000 [ 216K] r-x/rwx SM=COW ilename-extension

Thread 0 Crashed:
0 ??? 0x00000001189bf000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007fff51131bf8
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x00000001189bf000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x10eace000 - 0x10eb03fff +??? (0) <49481C32-6500-39EC-A289-69FF32BF76E4> (null)
0x1189be000 - 0x1189fbdc7 +??? (434) <6321D5CB-2FF7-387B-AE8D-B1BBDF8596F3> (null)

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 398
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=608K resident=0K(0%) swapped_out_or_unallocated=608K(100%)
Writable regions: Total=8404K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8404K(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Stack 8192K 2
__DATA 296K 5
__TEXT 464K 3
shared memory 8K 3
=========== ======= =======
TOTAL 64.9M 12

It would appear your copy of the app has not been properly signed. What happens if you enter the following in Terminal:

codesign -vv /Applications/

/Applications/ valid on disk
/Applications/ satisfies its Designated Requirement

Intriguing idea which suggests maybe a reinstall is in order?

Check to see if it somehow got quarantined:

xattr /Applications/

Nope, nothing there either.

It would seem this is an issue on Sierra and earlier OS versions. Send your log to support and hopefully you’ll see a 2.1.1 version soon.

Just had it happen again and jumped into Console …

default 2018-12-09 18:53:21.043878 -0500 DXOPhotoLab2 CFNetwork TIC TCP Conn Event [12:0x600003f981f0]: 2 Err(0)
error 2018-12-09 18:53:21.043924 -0500 DXOPhotoLab2 CFNetwork TIC TCP Conn Missing Error [12:0x600003f981f0]: Generating 3:-9806
default 2018-12-09 18:53:21.043955 -0500 DXOPhotoLab2 CFNetwork TIC TCP Conn Cancel [12:0x600003f981f0]
default 2018-12-09 18:53:21.043982 -0500 DXOPhotoLab2 CFNetwork TIC TCP Conn Destroyed [12:0x600003f981f0]
default 2018-12-09 18:53:21.044114 -0500 DXOPhotoLab2 CFNetwork NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9806)
error 2018-12-09 18:53:21.044213 -0500 DXOPhotoLab2 CFNetwork HTTP load failed (error code: -1200 [3:-9806])
error 2018-12-09 18:53:21.044277 -0500 DXOPhotoLab2 CFNetwork NSURLConnection finished with error - code -1200

Nothing there it would seem … There are now three files in /Library/Logs/DiagnosticReports named


(with different time stamps corresponding to force-quit actions, and where “Sparky” is the name of the machine) One of those is attached.

DXOPhotoLab2_2018-12-09-185932_Sparky.hang.txt (900.8 KB)

iMacPro, High Sierra 10.13.6,
MacBook Pro 2.9 GHz Intel Core i7, Sierra 10.12.6,
both with PL2.1.0 build 14

Haven’t been able to reproduce it here. Quit in all forms works as it should.

Hi All
I have the same problem with Sierra. Reported it to Support a couple of days ago - we tried a re-install but that didn’t fix it. They’ve sent me a file to record the problem which I’ve just returned to them.
At first they said they weren’t aware of this issue but seems others on Sierra are having it - I’m sure they’ve noticed this thread but maybe worth dropping them a note …

This happened for me yesterday. I had to kill the application by force.
I run version 2.1.0, build 14.
My OS is macOS High Sierra, version 10.13.6 on an iMac (Retina 5K, 27-inch, 2017) with 16 GB RAM and a 4.2 GHz processor.
This has never happened to me before and I use PhotoLAB nearly every day.

I am also running Sierra on a 2017 MacBook Pro and have had similar issues.

I am having the same issue. I have call costumer support with no lock. Im very frustrated, after installing the new update I run with this issue.
If any one have the solution to this problem please share it.
Best to all.

Are your account an admin account on your Mac or do you run PL as an ordinary user?

Myself as the opener of this thread is working as an admin from the beginning and through all DxO Versions.