Error Code 0x80070643

Downloaded the Nik 4 upgrade and the installation fails with this message:

(System is Windows 10 x64)

Error 0x80070643
There is a problem with this Windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

I tried the solution with Command Prompt:
Please proceed as follows:

  1. Click Start> Programs> Accessories.

  2. Right-click on Command Prompt, select “Run as administrator”.

  3. If you get C: \ Windows \ SysWow64>, go to step 4. Otherwise, enter the following text, including the quotation marks, and press Enter:
    cd “% systemroot% \ SysWow64”

  4. Then type regsvr32 jscript.dll and press the Enter key.
    Then try reinstalling DxO PhotoLab 4

And it did not work.

1 Like

I know it’s annoying - but have you tried downloading the Nik Collection 4 installer using a different web browser? Does the software download quickly and smoothly - or does it stall and sometimes fail? And are you running the installer from your local hard disk or from some other attached or remote media such as a SD card or network drive?

I solved the problem. Turns out that Adobe Lightroom had a corrupt catalog. Once I created a new catalog the installation went through without a hitch and worked perfect. Hopefully that helps others who might have the same problem.

1 Like