Error 0X80070659 when trying to install on windows 11

I recently bought new computer with Windows 11. I have tried to install newest versions of Nik Collection 5 and 6. I get an error with the code 0X80070659. I have tried to run Windows Troubleshooter and Restoro and neither has helped.


A search shows that it means that the installation is forbidden by your system policy. Does your user account have administrator privileges? It seems the new computer wasn’t set up properly or you have some other problem that requires Windows expertise to fix. Best to take it one step at a time. Check the user account privileges first.

1 Like

Have you tried to install with right click at the setup file and choose run as administrator?

Hi Greg. I do have admin rights but I actually ran the install program as an admin. I also ran the following commands:

Dism /Online /Cleanup-Image /ScanHealth
Dism /Online /Cleanup-Image /RestoreHealth
sfc /scannow

and while the scans found and fixed corrupt files it did not resolve my problem.


Maybe your Net 6.x installation is not installed correctly. I’ve found some threads by German Datev installation with the same problems. If the setup needs some libraries from the net desktop runtime, it will try to download in the background. Some threads says that the confirmation for installing this lays in the background and will not be notices by the user.

Hi Folks. Greg, I’ve tried everything you had suggested without success.

Guenterm, thank you for your suggestion. I’ve run various Windows troubleshooting programs. Would that have detected an incorrectly installed Net 6? Should I upgrade to Net 7? How do I go about reinstalling Net 6?


maybe you can try to download from here Download .NET 6.0 (Linux, macOS, and Windows) (
and choose the .NET Desktop Runtime 6.0.16
If troubleshooting programs detect a missing version…I’m not sure about.
By searching for this theme I’ve found how to detect whether .NET 6.0 desktop runtime 6.0.8 is installed or not - Microsoft Q&A

Please remember that my idea was by searching for other programs, not for DXO…so maybe we are looking in the wrong direction :sunglasses:


The problem was the Smart App Control in Windows. Once I turned that off Nik 6 loaded fine.


1 Like