DxO PureRaw Fails to Install on MacBookPro (Big Sur 11.4) & DxO fails to provide support

DxO support has failed to fix its latest version of DxO PureRaw so that it will install. I have a MacBook Pro (2019 model) running Big Sur 11.4 and it failed to install on it about 3 weeks after I originally installed the program on my iMac and it runs fine. But not on my MacBook Pro. After going back and forth with DxO support for weeks, a support tech asked me to run a diagnostic, providing me the software, and asked me to upload it to them for review. That was May 28 and I have had zero support or response from DxO since then. I am extremely disappointed. I did everything I could including wiping all software from my MacBook Pro and reinstalling the MacOS. It still fails to install.

Hi, Steve. Going by what you’ve shared, it sounds like support has taken some good steps toward helping you, but the process has been moving much too slowly. Have they told you to expect a long wait, or given you an explanation for why the problem isn’t solved yet?

If you haven’t already, I suggest updating your support ticket with a request that it be escalated to the support manager for review on the basis that the process is taking too long and you are still completely unable to use the software.

Thank you Greg. Through what process do I escalate my issue? The tech who was helpful did not give me a timeline for a response to the diagnostic that I performed for them and uploaded for their review. That was May 28. Maybe I am being too impatient.


@Steve, have you tried to copy the app from your iMac to your MacBook?

Hi Steve I had identical problem and also completed their diagnostic test on May 23 (4 weeks ago) So far no response and the trial period has now expired

As of just now, both PureRaw and PhotoLab Essential Edition (excludes deepPrime) cost 129 Euros.

Under these conditions, I’d throw in another 70 Euros and get PhotoLab Elite Edition instead, a much better value imo…


same problem for me : Macbook pro 16 2019 and not to lauch Pureraw after the installation.
Nothing appens and no solution form the support…

I don’t have the same problem but DxO elite is buggy on my brand new Macbook Pro. Spent hours trying to fix (including reinstall) following which DxO variously blamed me or my machine set-up. Eventually sent off diagnostic test and am told a fix will be sent out “in a few weeks”. At no point have DxO apologised for any of this which probably irritates me as much as anything else. Given DxO do not support my most used lens (Olympus 150-400) which undermines the two main selling points of DxO to me (lens correction/sharpen and Deep Prime - the latter because I am having to use jpegs mostly to achieve optimal sharpness) I am probably about to give up and, reluctantly, embrace LR/CC)

I am running both DXO PL Elite and PR. One is on BigSur (11.3.1) and the other is on Catalina (10.15.7). I had a short problem with BigSur and DXO, but DXO had me clean out the first install and re-install it. No problems. It is on an Intel i9 and the Catalina is an old Intel i7. I am curious if you are running the Apple silicone M1. I don’t remember when they began making the M1 machines, but I have not heard too much negative with DXO. I have with Capture One 21, but they got that settled quickly. I would follow Egregius’ advice, and send them a note with your ticket number and tell them you would like to hear from them soon. I’ve not had a no-response problem but never had the difficulties as you seem to be having. I’ll keep a watch on this thread. Good luck to you!

I am looking for answers on similar problems with PureRAW on my MacBook Pro. I have sent sub-mentioned message to DXO support. As I see your discussion, I expect they’re working on it, but they didn’t solve it, obviously.

I installed DXO PureRAW on my iMac with macOS 11.5.2. Everything went well.

Then I installed DXO PureRAW on my MacBook Pro macOS 11.5.2. Everything event well till the moment I press the button “Process Photos”.
I get the popup screen for RAW Processing then I click “Process” and de progress line occurs but nothing happens further. No progress anymore.

How can I solve this?

It is now over 2 months since I last heard anything from DxO support in troubleshooting why PureRaw does not install on my MacBook Pro. I installed it first on my iMac and it works fine, but it has never installed on my MacBook Pro. I have reinstalled my MacOS and PureRaw still fails to install. When I try to start the install, the PureRaw name briefly appears on my menu bar and then disappears.

I first reported the issue with DxO support right after buying PureRaw in April 2021 and in late May, after numerous emails for support, they urged me to perform a diagnostic test on my computer which I uploaded to DxO.

Two months later, in July, I again asked for an update on my case the the DxO support person asked me to remain patient. Now it is September 25, and I have received zero support for DxO.

I have tried everything including copying the application from my iMac. Same result.

When I find things aren’t working right on my Macs, Maintenance is always my go-to utility to get a system back in order when things get wonky. It’s free and it doesn’t put crap on your system. If I were you, I would try uninstalling PureRaw, running Maintenance with its default settings, and reinstalling PureRaw. I’ve found Maintenance to be very reliable and can’t imagine it could hurt.