DXO PureRAW 3 reimport bug

I’m trying PureRAW 3 on my Mac in combination with latest Lightroom Classic.

The plugin sends the file to PureRAW 3, safes the new DNG to the DXO folder, but the file will not be imported automatically. I have to synchronize the folder.

Is it just a limitation of the test version?

I had the same issue. My issue was that there was a conflict with PureRaw 2. Once I completely deleted PureRaw 2 from my Mac, the error message did not reappear and the file was imported correctly.

Thank you for your response. But it didn’t work for me.
I ran the PR2 uninstall app, uninstalled PR3 and installed it fresh again.
No import, just the prompt “?:0: attempt to concatenate a nil value”

I’ll try to contact the support team directly.

Unfortunately the uninstall app won’t completely uninstall the conflicting files. You need to open finder, then the ‘go to’ command from the menu at the top of the screen. Searh DXO PURERAW2 and delete every folder and file that is shown. Then empty your trash folder.

I found an issue with DPR installing plugins with links to wrong places. Deleting the plugins and reinstalling them solved that issue. See below for location and file names

501@iMac-2019 ~/Library/Application Support/Adobe/Lightroom/Modules % ls -n

drwxr-xr-x   7 501  20  224 18 Mär 07:59 DxO-PureRawv2.import.lrplugin
drwxr-xr-x  23 501  20  736 18 Mär 07:59 DxO-PureRawv2.lrplugin
drwxr-xr-x   7 501  20  224  2 Feb 12:00 DxO-PureRawv3.import.lrplugin
drwxr-xr-x  22 501  20  704  2 Feb 12:07 DxO-PureRawv3.lrplugin

Tested using both DPR2 and DPR3 as plugins to Lr Classic on macOS Monterey 12.6.3 on iMac 2019


  • DPR3 does not seem to check plugins that have been installed by previous versions. The ones I deleted had paths to DPR that were right a few days ago, before I moved the applications to a different folder - and installing DPR3 again did not replace the plugins
  • DPR2 has a menu that allows manual installation of plugins and Finder actions
    DPR3 has no such menu. Bringing back that menu could provide an easy fix for plugin issues.
  • DPR’s installers can’t cope with multiple user accounts. Plugins and Finder actions are therefore only installed on the account that was used when installing. Again, the install menu of DPR2 solves that issue…while DPR3 presents a dialog (in very small, low contrast print) that is maybe not yet adapted to retina type displays.

Pat, Platypus
Thanks again for your input and informations.
I have tried a lot, but to no avail.
Now I’m waiting for the response of the support team.

DeepPrime XD is truly a bit better than DeepPrime of the PureRaw1.6, but if the workflow does not work easier, the update price is not worth it for me. I hope support can bring a fix.

The new update PureRaw 3.1.0 Build 532 and the Plugins 3.1.532.0 fixed it for me.
Now it works as it should and I updated to PR3

I’m happy