DXO PureRAW 2.2.1 using DeepPrime is failing with all NEF files I've tried

Here’s a sample of an image taken with a Nikon D850 a few years ago (so it should be using a well-worn NEF format). It’s supposed to be two eagles going at each other.


Every image I’ve tried with DeepPrime comes out looking similar to this. If I use just Prime, all seems fine.

I’ve tried converting to DNG first, same result.

My graphics card is a GeForce RTX 2070, if it matters at all.

Hi Jim and welcome,

Looks like something is corrupted somewhere. I would try uninstalling the program then downloading a fresh copy of the program and reinstalling.

1 Like

Since DeepPRIME relies on the graphics processor when possible, that could be your culprit. Make sure PureRAW is configured to do that and that your nVidia drivers are up-to-date. (I use the Studio driver but the Game driver should be fine also.) If the problem persists, run a test program such as FurMark to rule out a graphics card malfunction.

Do you have the latest Studio drivers from the Nvidia website? These specifically mention compatibility with DXO-Photolab.

Thanks for the responses. Turned out to be the GeForce Driver after all. I’m on 522.30 (Studio) now.

1 Like

I’m having an issue with DXO pureraw 2. Trying to get customer service to request a refund, but I cannot find any hepl on their web site.

What is the issue? Did you get a newer unsupported camera since finishing your 30-day free trial? Can you be more specific.