DxO Pure Raw 3 (3.8.0) hangs on every image

I’ve been using PureRaw since v2 with no issues, but starting recently I can’t process any raw (.NEF) filles - even files that I processed in the past. I’m using v3.8.0 and processing DeepPrimeXD with all of the default options to a DNG file. Sometimes the progress bar never starts to move; other times it gets somewhere in the middle and stops. If I wait long enough (at least 5 minutes) I may get a vague message that an error occurred, but there aren’t any details in the message. I’ve uninstalled and re-installed, but no different.

I’ve sent a message to DxO support a few days ago, but no response yet.

I’m using Windows 11, i7 12th gen, 64gb ram, NVIDIA 3070 with latest drivers.

DxO support can take some time to answer support requests. It’s best to be patient.

Meanwhile, you could try to use DeepPRIME instead of DeepPRIME XD. DPXD can work miracles, but is not a cure-all, as you can find e.g. in a recent post in the PhotoLab section of the forum. DeepPRIME might work just as well, but without the issue you have with DPXD.

And last but not least: Welcome to DxO wonderland, @bertsirkin

I tried DeepPrime but that fails also. I also tried uninstalling and installing the previous version (3.7), but that’s doing the same thing. There’s some kind of conflict, but nothing has changed on the computer recently. I looked, but can’t find any kind of log file from DxO.

Hello @bertsirkin

Have you tried switching between using the CPU or GPU for processing? (GPU is obviously preferable for speed.)

I’m assuming you have Nvidia’s latest Studio driver installed? Also this months Windows Patch Tuesday was recent (don’t know if there were any related issues).

Could you share one of the files if you can upload?

Also regarding DxO Support - did you at least get the automated reply with a ticket number? If yes and it’s been 3 days, I’d reply to that e-mail and ask for an update.

I any case, welcome and hope you get it sorted soon.

I do have the latest Studio Driver installed.

I just tried manually selecting the NVIDIA GPU, CPU onboard Intel GPU and all had the same results - nothing processed.

It’s not an issue with the RAW files as I can process them on my laptop, just not on my desktop.

I did get an automated reply and ticket number, so I’ll just wait until I hear from them.

One time I did get an error message, but only after leaving it process for a long time (half hour or more).


Looks like the issue is caused by the installation of DPR on your desktop or by its configuration or some interoperability issue.

Occasionally, I had issues with installations and was advised by DxO to completely remove any traces of an app before installing it again. While I could advise on how to do this on Mac, someone with a Win background would have to jump in for your issue.

One last question: Have you tested with antivirus and other security switched off?

There’s some conflict, but it would be nice if DPR had some sort of debugging log. I did try it without antivirus turned off.

Rather than trying to remove every bit of DPR from the OS registry, I’ll wait until I hear from DxO.


Have you checked the files in the following folder?

C:\Users\%USERPROFILE%\AppData\Local\DxO_Labs\DxO PureRAW 3\Logs

Thanks! I found the log files.

Strangely, the log file indicates the output was written, but it wasn’t. These are the entries from an attempt to process a raw file I just tried - the last entry indicates the output file was saved, but, although the “DxO” folder was created, the file wasn’t.

The next-to last entry indicates it was loading a .CAF file from a “DxO Pure Raw 2” folder (not DxO 3). That seems strange.

1705260010.448 [39992] INFO ImageSaver.txt <> - CE INFO: ConvertFromExifLightSourceToWBMode: Ignoring exif::LightSource value Unknown 0

1705260010.902 [39992] INFO ImageSaver.txt <> - BackgroundProcessing::processImage: Input image file path: P:/Frost2023/NIKON D850_3018326__8505843.NEF

1705260010.902 [39992] INFO ImageSaver.txt <> - BackgroundProcessing::tryToLoadCafModule: Try to load caf module: C:/Users/bert/AppData/Local/DxO_Labs/DxO PureRAW 2/Modules\C52108b_001.caf

1705260010.906 [39992] DEBUG ImageSaver.txt <> - BackgroundProcessing::saveAsDNG: Image is saved to DNG file: P:/Frost2023/DxO/NIKON D850_3018326__8505843-NEF_DxO_DeepPRIMEXD.dng


Without editing the registry, you can try the clean reinstallation procedure described for PhotoLab. Couldn’t find the same on the site for PureRaw with a quick search, however installation looks very similar apart from locations of some folders.

For the first location substitute “DxO PhotoLab” with “DxO PureRAW” and for the other three substitute “DxO” with “DxO_Labs”.

Quote worth mentioning from the page:

“Some issues can be solved by reinstalling DxO PhotoLab using the method described below. We ask that you please try this before opening a support ticket.”

And then also this:

Thanks!!! That did it.

I couldn’t follow those instructions as I would have deleted the NIK software, but I renamed the DPR v2 folder (not sure why it was still there as it was uninstalled a long time ago) and the DPR v3 folder under the user accounts. I did an uninstall, which deleted everything in the “Program Files\DxO” folder. I rebooted, reinstalled v3.8 and it worked first time. After seeing the reference to a DPR V2 file in the log, I suspected v2 files may have been the issue.

Thanks again!

…and DxO seems to know about such possible sources of headache 'cause of the recommendation to fully uninstall…but the uninstaller is not thorough enough for that job.

Nevertheless, as your issue has been resolved: :+1: :+1: :+1:

Best Practice: For complete uninstalls, I usually search the drive for anything DxO with respective search terms and with “Find Any File” or “Easy Find”, two apps that are available for macOS only. In case of PurerRAW, search terms can be

*pureraw*, *dprv*, com.dxo*  etc.

The strange thing is that I upgraded to v3 a long time ago, and haven’t had an issue until now.

Thanks for your help.