DXO PR4 application fails to load as stand alone Mac OS Sonoma

Is anyone else having issues loading DXO PR4 as a stand-alone application in Mac OS Sonoma?
It will also not load when clicking on a file with any Raw files despite being the default application.
It appears to be working as a LR Classic plug-in.

Have you checked the default file association?

At the moment, NEF files are opened with PhotoLab 6, but you can choose from any other compatible app and make it the default for all files with the same extension…

No such problem here. DPR4 simply takes a few seconds to launch.

Hi Joanna,
yes, I checked,

Even when I went into the applications folder and tried to launch it from there it would not load.
It would only load as a Lightroom Plug-in.

I think I tracked the issue down to “PureRawv4MacLaunchHelper” application was not opening at login to the Mac Studio. Also noted the PR4 widget in the top toolbar was missing.
When I had the issue I looked at the Mac “Force Quit” to see if there was anything relating to PR4, but none was found, so I restarted the Mac and this time I saw that PureRawv4MacLaunchHelper was in the running applications in “Force Quit” window.
I now look at the “login items” and PureRawv4MacLaunchHelper now appears to be running.
The issue may have come about as I still have PR2 & 3 still on my system.

@Locheil, the login item does not have to be installed or active. DPR starts in standalone without it too on macOS 14.3.1. I’m currently updating to macOS 14.4 and will check if that changes DPR in standalone use. More about it later…

Update: DPR4 launches on double-click on macOS 14.4

Issue resolved by deleting the “PureRawv4MacLaunchHelper” application from the Login items within the IOS Sonoma General> Login items menu.

I can now open RAW files from the iOS file manager into DXO PR4, and the DXO PR4 application will open directly from the applications folder.

LR CC plug-in is also working ok.

I think you’ll find that should be macOS :nerd_face:

Yep… brain :dash: !

I am also having the problem where PureRaw 4 will not launch. I downloaded it yesterday and it worked for a while then after closing it would not reopen. I uninstalled and reinstalled the program and it worked again. I opened and closed it multiple times to test it and there were no problems. Today it is not launching again. From the above discussion I checked and see “PureRawv4MacLaunchHelper” in my Open at Login Items. I don’t know why this has to be there and why DxO put this in the installer. I only have 3 others others listed and those are all programs that I want opening at login. What are the possible consequences if I delete this? I assume this is a bug?

One more thing, I restarted my computer to see if that would help. I saw “PureRawv4MacLaunchHelper” appear on the upper left during start up before the “Apple” appeared.

Just deleting PureRawv4MacLaunchHelper from the login items worked for me. Restarted the iMac, and it’s no longer in the list of login items, and PR4 then works as advertised.

On the Mac this “LaunchHelp” is being put into Login Items which is very unusual on a Mac. Does anyone know why? DxO recently stated they would start disabling the program after 30 days if a user didn’t open the app while connected to the internet. Is it possible this has to do with this intrusive change?

Just trying to understand why it is part of the installer and what the effect might be of removing it.

Same with me. I removed the Launch Helper from my login list in Sonoma and everything works fine, also after restart of the computer.

Note the name “Launch Helper”. Question remains: Who is the lucky one being helped?

Same problem with me. Aggravating. Had to reinstall the app. Happened Sevela times and expect problem to continue -not a one time problem.

Have you removed the helper tool from the login items as described in some of the previous posts?

Reinstalling DPR will add the login helper again and if removing the helper solved the issue, the issue will return with re-installing DPR.

DxO must have an agenda concerning the login helper, but as of now, the implementation is counter-productive and I hope that DxO will be able to solve the problem without yet another helper tool. As for the “why”, I suppose that the helper is related to protecting installation limits, to make sure that our DPR app is a legitimate copy or something like that. In the end, it must be about money :money_mouth_face::money_mouth_face::money_mouth_face:

Appears to have fixed it.Many many thanks

I just updated PR4 to build 4.0.1. , the issue persists with me once again having to delete “PureRawv4MacLaunchHelper” from my “Open at Login Items” to fix problems noted previously.
Mac Studio M1Max with Studio display. I’m running on Sonoma 14.3.1

Have the same bug as well! Macbook Air M2, macOS 14.4.1, DXO Pureraw 4.0.1

Use the routine mentioned in the previous post to work around the issue.