DXO PL5 crashes at launch


I’ve had a case open for more than a week with support for PL5. They have debug reports, etc. and unfortunately have now femailed me saying “it’s a complex issue” and basically, stop contacting them, because it drops my case to the bottom of the developer queue. This is absurd and not exactly a good customer support workflow.

This isn’t a complex issue…PL5 is completely useless as it won’t even open on my system with the files I actually care about, Nikon RAW/NEF. Could I ask you to either sort this or issue me a refund for the upgrade until the product actually does something?


1 Like

Good morning @gioan and welcome to the forum,

Which operation system are you working on? What is your support ticket id?

  • And this one should be requested not via the forum thread but via support.

Thank you
Svetlana G.

Hi Svetlana, kak dela?

I’m not “working” on anything, as the program crashes immediately upon selecting a folder with NEF/RAW files. Files are from Nikon (corrected!) Z6, D810s, D850s, on local and remote (network) drive. Same result, immediate crash, with or without DeepPrime/GPU utilized, seems to be limited to the Z6 and D850 files.
“#297063 [Support & Assistance] Request n°297063” is what they’ve sent.
I did ask them for an update or a refund, unfortunately they did not reply to that and instead requested I not contact them as it screws up their queue system, they’ll contact me. Pretty broken flowchart if you ask me.

I’ve even since tried a reinstall and an OS upgrade (to Monterey) in case it helps, unfortunately same results.

If there’s anything you can suggest, let me know. Thank you for the assistance.



Good morning @gioan ,

  • Horosho, spasibo :slight_smile: . How are you?

Well, as it’s connected to Mac, I’ve moved the post to the dedicated section. And let me ask @SebinParis to assist here.

Svetlana G.

Thank you Svetlana.

@SebinParis any suggestions? Nothing from support, nor anything here.

PL5 ( still crashes immediately on launch. I was wrong, it crashes on all NEF, whether Nikon D810, D850 or z6 (I thought it was fine with 810 but had only looked at one directory with 2 files).

DXO has been my go-to software for years, but the latest release isn’t exactly looking good.



Sadly, another week and nothing from support or anyone here.

What would you recommend at this point?


I just checked the ticket, and the response should be coming back to you shortly. The skinny of it that it will be fixed in an upcoming version.

@kettch thank you for the update. Brilliant :frowning: . I guess I shouldn’t have uninstalled Dxo4 in exuberant blind optimism.

I suppose a credit/refund is rather pointless as I’d rather have the functional software.

Will try the reinstall of 4 and hope for the best on the fix for the “latest” version.


Since installing a new version of PhotoLab never overlays previous versions, it’s always a good idea not to uninstall the older version until you’re sure the new version is working to your satisfaction.

In addition I find it useful to keep an older version installed for some period of time In case some tool or feature does not seem to be operating the way I remember it. Many of us have been able to find and report on minor bugs in new versions without having to resort to our memories alone.

I upgraded to PL 5 on October 20th, but I have no plans to uninstall version 4 until at least the end of the year.


There is a high learning curve here and I find that I am continually seeing new angles to the DxO theory…almost an endless body of knowledge…