DxO PL 6: Cannot open RAW files anymore - SetFromUserParams fails

Suddenly, I’m unable to open any RAW files with PL6. Even those images which I worked on a few weeks ago. I first thought it was an issue with the latest version of Lightroom Classic (from which I invoke PL) but it’s the same when I open PL as a standalone app. I first noticed this with PL 6.10 today. 6.11 doesn’t change anything.

Any ideas what I can do to figure out what’s wrong here?

Something changed to cause this - maybe an OS update or user account change? A failing storage device? Or something affected your registry in a bad way? You could try support.dxo.com, but it might be quicker to check a few things on your own. If simply rebooting doesn’t help, I suggest first looking in the Event Viewer at the System and Application logs and also in the PhotoLab log file in your Documents folder. Run a program that does a SMART check on your storage devices. Also use the sfc and dism commands (you can search online for instructions if you haven’t run these before). Try disabling your security software, too. Good to check everything out when something strange like this happens.

1 Like

The couple of times I have had PhotoLab refuse to do basic tasks (open, export, etc) I have contacted DxO Support and the first thing they always suggest is to re-install the application. It usually fixes gross failures like these.

1 Like

Karsten installed PhotoLab 6.11, which not only overwrites 6.10 but uninstalls and reinstalls the software. Since that didn’t fix the problem, there’s reason for concern that something more system-wide has gone wrong.

1 Like

I found this old thread that solved my problem. A few days ago, I reorganized / relocated custom DCP profiles that I use both in Lightroom and PL. Hence, the DCP file specified in the Color Rendering section could not be found by PL.

Thank you for your comments!

…which shows the need to be able to move the DCP profile along with the image
rather than being constrained by the absolute path.

@DxO_Support-Team – please take note !

1 Like

Its just another 1/2 finished feature. I thought they had at least amended it so if the DCP wasn’t at the location it defaulted to a PL default. At least thats with the windows version

I don’t see a relationship between the location of DCP profiles (for me, located under my Windows user profile in Adobe\CameraRaw ) and image files.
However, a clear error message which file could not be opened would have helped to easily understand and fix the problem.

Ok, I’ll try with some explanation. :slight_smile:

You were talking about dcp-pofiles in PL6, which you might have stored like
Screen Shot 11-11-23 at 03.02 PM

Then after import you could choose

BUT when moving the source file → you break the registered (absolute) path.

In addition, in PL7 you can create your own DCP profile, which by default is stored together with the pic
Screen Shot 11-11-23 at 03.08 PM
Screen Shot 11-11-23 at 03.14 PM

IF to make it generally available, you better store it in a “permanent” location, like
Screen Shot 11-11-23 at 03.10 PM
either directly (and changing the default path each time !)

by copying it to the new location and importing in PL7
Screen Shot 11-11-23 at 03.15 PM
( shown here in both locations )

BUT again, when moving the source file → one breaks the registered (absolute) path.

see more …

1 Like

@Wolfgang I absolutely agree. My comment was a response to your earlier statement where you required to move the DCP profile along with the image. Just a misunderstanding in terminology.

yes, forgot to mention …

When stored with the image (which makes sense) but currently with an absolute path
and one decides to move the pic (of course together with the corresponding dcp-profile)

  • within PL
    the dcp-file is not moved / still accessible from the old location (but orphaned)

  • outside of PL
    the dcp-profile is moved / no more accessible (cause of the absolute path)