DXO PL 6.3.1 - Crash on Dialog to Select Destination Folder in Export

For me, when I select to specify a destination folder in the export dialog, DXO crashes.

Steps that make it reproduce: once in the Windows file selection dialog to specify output folder, DXO occupies one CPU core at 100% and continuously churns on it and is no longer responsive. Cannot get out of the dialog. All disk I/O is 0%.

Win 10 up to date, 13900k, RTX4090, PL 6.3.1. System is stable (besides selecting folder isn’t much of any computation). It is not related to network drive or USB peripheral wake up lag that can pause a file dialog and recover. Symptoms of endless churning CPU could be some memory/pointer bug of some kind? Everything else seems to work fine.

So my workaround is just export to same directory, but it is an annoyance to my workflow.

Still wondering if it is something specific to what I may be doing, as I would think this would cause more ruckus on the forums if it was happening to everyone! Anyone else have this issue or can replicate, or confirm that their dialog works just fine?



1 Like

Hello @AvengingAB,

This issue is most probably related to a third-party application (a shell extension) which makes DxO PhotoLab instable.
Can you please open a support ticket and let us know if you use for instance Dell Backup and Recovery, which is known for causing such issues. (for example, it’s reported on AutoDesk FAQ Opening file dialog causes a crash with various Autodesk products | 3ds Max | Autodesk Knowledge Network)

1 Like

@AvengingAB I am afraid you will need to be more specific with respect to you workflow in this specific case because it works fine on my Win10 i7 4790K (RTX 3060) PL6.3.1.

The machine is busy doing other things but DxOPhotoLab is being well enough behaved while I search for the target export directory.

@Barbara-S Sorry I missed seeing your post before making mine.

I am experiencing the same or similar problem. If I try to export a processed file the dialogue boxes grey out and I have to force close the program

I have yet to see if this is the problem, but it seems that Avast software maybe the problem

Thanks guys for offering suggestions.

Thanks @stevepaint on pointing out the Avast, this was 100% the problem for me, and your symptoms sound exactly the same. At first I tried just disabling the Avast Shields, but that did not work to fix the problem – I had to literally uninstall Avast completely and then the dialog no longer caused DXO to freeze when specifying folder in the export window.

It was working once before without issues though. Could we please file this as a bug for backlog? Hopefully DXO and Avast can play nice together again in a future update.

1 Like

Last week, PL stopped operating following an Avast update at the start of the week.
And then another update solved the problem.
Or is this another problem?

I’m running latest Avast (whatever is updated automatically) and latest DxO PL 6.3.1.

I can double confirm it is caused by Avast and DxO interaction. DxO was freezing as aforementioned, after uninstalling Avast, works fine with the export folder dialog. Then after rebooting again, PL works fine still. Then when I reinstalled Avast, nothing special just the basics File/Behavior/Web shields, the PL is crashing in the same manner again.

No notifications or warnings from Avast either, it did not seem to flag anything.

Not sure what’s going on, but just some other data points.

1 Like

Ok I’m now seeing if AVG is ok to use

Just installed AVG and an identical issue
What’s the recommendation for virus software???

@stevepaint I had forgotten all about the idea that Virus protection software could cause issues with other software.

My main machine has an ancient unlimited licence for Malwarebytes, originally unlimited in number of machines and length of time, but now restricted to one machine and very expensive if I had to buy it now.

I also have Kerish Doctor keeping a watchful eye on this and that.

Although I have a Household license for Kaspersky that is actually not installed on my test system which is only watched over by Microsoft Defender

There is a free version of Malwarebytes which I use.
I have installed Bitdefender and at present photolab6 and 5 both work normally.

I use Windows Security (Defender) plus Malwarebytes Premium. Zero problems and what I perceive to be excellent protection.

I ditched Avast! and AVG years ago for problems like these. I used them on numerous computers and it seemed they were getting worse over time instead of better. When it got to the point that I had to reinstall Windows and all of my applications, I’d had enough. They interfere with the OS too much, with many false positives.

1 Like

I only use Windows Security and have no issues as long as you don’t invite people in by clicking dodgy links.

I also bought a router that has Trend AV installed which protects ALL my devices connected to the internet via the router - works a treat!

A little off-specific-topic - - but this may be useful, if you’re not already aware of it …

You can specify a relative destination folder - which can be a permanent target location;
For example; image

  • directs exports to a folder named “DxO” beneath whichever folder PL us currently working within.

John M

Thanks @John-M, that is a nice tip! I had been doing pasting in an absolute path, but your relative method works much easier.

There have been cases where Avast has been useful for me and demonstrates robust protection. For the different real-time antivirus, I think it’s going to end up being YMMV per person.

I think it’s a pretty reasonable ask for DxO maintain this on their latest version on this, so hope it can get fixed, but I will do workaround for the time being.

1 Like

It looks like not only Avast is the problem.

I uninstalled Avast, and Photolab started working again.

I then installed AVG, and… the same problem returned!!!

At first I was blaming Avast. Now that this problem persists BOTH with Avast and AVG, I think that the problem is Photolab is badly written: it’s too much of a coincidence if the same issue happens with TWO different antivirus programs!

1 Like

Agreed, I should not be expected to completely uninstall antivirus or install another antivirus I am not familiar with as a resolution to this. I was being nice, but quite frankly that is simply ridiculous.

On the main page now, I see a whole host of other issues people are having on other threads related to Photolab having bad interactions with antivirus software.

We effectively pay annual support fee in order to upgrade to latest DxO; DxO needs to officially acknowledge these issues and fix.

1 Like

If you have been reading all the posts on the Avast issues you would have also read one from DxO that they have been in conversation with Avast and that Avast has already released a fix to their software. If that fix addresses this issue then it was premature to blame DxO. Avast is well known to have caused issues with various software titles over the years. Why would anyone think that it is DxO’s fault when an antivirus program interferes with PhotoLab? It seems that whenever there is a conflict between PhotoLab and other software, DxO is always seen as the guilty party until they can prove their innocence instead of the other way around.


Latest versions does not fix this particular issue, I just tested it.

I don’t have a problem with what you are saying. I agree with you.

To be fair, this thread has been more on antivirus bashing, and the solutions presented were around how antivirus is crappy and causing all kinds of issues. I wanted to hear 15 second acknowledgment from DxO that this issue is on their radar and being looked at and that is all.

Program interaction is a two way street, and they have to figure it out, and that is fine. It is what I am asking.

All that being said, I have a lot of programs installed and whether it was Avast or DxO, the antivirus doesn’t crash them and bring them to their knees from a sudden update on either end.

But I don’t think this is will be a productive route of discussion to go down. I will just say that I am glad if they are looking into it and I think we can all agree on that…