DXo PhotoLab2: Sony A7III modules

I run the programme just a few minutes ago and it started with a message that the PL database was moved and a new one was created. Thereafter all lens modules relating to Sony alpha 7 III disappeared. When I am trying to download them, they fail to download.
Is anyone experiencing a similar problem?


First, the changes of the database should not influence on the modules at all.
Second, can you, please, check if you still have the modules here - %LocalAppData%\DxO\DxO PhotoLab 2\Modules ?

Third, what message do you see when you try to download the modules and fail?

Waiting for your replies for a further investigation.

Svetlana G.

Which programme should I use to insert the text you have provided?

This has to go to the address bar of Windows file Explorer. It points to a usually hidden folder in your local file system.

  • Yes, exactly, type it in the Windows Explorer. But I forgot to ask you, maybe you work on Mac?

Svetlana G.

Indeed I work on a Mac

In this case, check if you still have the modules
~/Library/DxO PhotoLab v2/Modules

I solved this issue along with the one reported under Filmpack 5. Please my response there regarding what was the likely cause of the Photolab malfunctioning I had experienced.