DXO Photolab bug

I use Photolab with Ligtroom and photoshop. With the latest update, after 3 to 5 export to anywhere, I have an unkown error and cannot export. The only way I found to retrieve the function is to reboot my computer.
This is really annoying. For what I saw, it seems to be the deepPrime function. Totally frustrating. I already sent a message to the support a few weeks ago wihtout any answer. Maybe a better chance here.

Please tell us step by step what you are doing before you get the error. Maybe we can reproduce it. What’s your OS and version thereof?

Yesterday, I tried without DeePrime and the export worked fine. The steps are:

  • export from Lightroom to DXO Photoloba
  • DeepPrime
  • ClearView
  • Smart Lighting
  • Export to Ligtroom or Photoshop or Disk → Unknown error
    If I don’t do the “DeepPrime”, the export is successful
  • If I reboot my computer, I can export (with DeepPrime) without issue 3 to 6 times, then error

It could be your GPU is causing the issue. Go to settings and turn off GPU and try again with DeepPrime. If that fixes your problem them most likely your GPU is not powerful enough to do the job.

1 Like

That is definitely the first thing I would try. However, it’s not clear from his first post whether the 3 to 5 successful exports he mentioned were using DeepPRIME. If he has been unable to process anything using DeepPRIME, the GPU is almost definitely the cause. I would also uncheck OpenCL in preferences, although that is less likely to be a problem.


My system is:

  • I7 7700K
  • AMD Radeon RX480 8GB VRAM
  • 64 Gb RAM
  • DXO Cache on a 500Go NVME Samsung (dedicated to cache for Photoshop, Lightroom and DXO)
    I just did the test, deengage the GPU, restart DXO, did the DeepPrime and the export, fine, it did… But I am curious, so I reengaged the GPU, then DeepPrime, and the export worked.

So, there is definitely something to do between the GPU and the CPU, But, if a RX480 with 8Gb of VRAM is not enough for tiff or jpg, what kind of GPU do I need?

When this happens, try quitting Lightroom and try the export again.

Good morning,

Let me ask @Lucas to analyze the issue.

Thank you
Svetlana G.

Hello @fingernose,

GPUs recommended for DeepPRIME are listed in our release notes and support page about DeepPRIME.

That being said, your GPU looks rather good although a bit below our recommendations. I would first try to update the graphics drivers to version 21.2.3 or later. We’ve seen issues with previous drivers and RX 500 series GPUs with the GPU randomly hanging, and your issue looks similar.



His RX 480 may be below your recommendations but it is a lot better spec’d than my Nvidia GTX 1050ti and I have had no problems running DeepPRIME with my card. My 7D Mark II files are processed over three times faster with the GTX 1050ti (22 secs) than when using my CPU (75 secs).